summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2022-02-14 13:06:19 -0500
committerRick Farina <zerochaos@gentoo.org>2022-02-14 13:07:07 -0500
commit55876d96812afb6518ebfb6f7438fb3044aba617 (patch)
tree24eed392be87662fb27cac18a3dc862b2ba8f58a
parentsci-electronics/eagle: allow unsplit e2fsprogs for -libs (diff)
downloadgentoo-55876d96812afb6518ebfb6f7438fb3044aba617.tar.gz
gentoo-55876d96812afb6518ebfb6f7438fb3044aba617.tar.bz2
gentoo-55876d96812afb6518ebfb6f7438fb3044aba617.zip
net-analyzer/ostinato: fix pkgcheck warnings
Add missing dep Closes: https://bugs.gentoo.org/789633 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-analyzer/ostinato/ostinato-1.1-r2.ebuild (renamed from net-analyzer/ostinato/ostinato-1.1-r1.ebuild)11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-analyzer/ostinato/ostinato-1.1-r1.ebuild b/net-analyzer/ostinato/ostinato-1.1-r2.ebuild
index 2b835a9bcecf..bccd03f406c0 100644
--- a/net-analyzer/ostinato/ostinato-1.1-r1.ebuild
+++ b/net-analyzer/ostinato/ostinato-1.1-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit qmake-utils
@@ -24,6 +24,7 @@ DEPEND="
dev-qt/qtscript:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
+ dev-libs/libnl:=
>=net-libs/libpcap-1.8.1-r2
"
RDEPEND="${DEPEND}"
@@ -33,5 +34,9 @@ PATCHES=(
)
src_configure() {
- eqmake5 PREFIX="${ED}/usr" ost.pro
+ eqmake5 PREFIX="/usr" ost.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
}