summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-19 15:19:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-19 16:51:50 +0200
commit566e8c514b2dadd29ba5f6377f6fcfd229cc46a0 (patch)
treebb48df6b545d5ce355bee3172a5673ec26700585
parentx11-misc/slock: Apply patch for CVE-2016-6866 (bug #591664). (diff)
downloadgentoo-566e8c514b2dadd29ba5f6377f6fcfd229cc46a0.tar.gz
gentoo-566e8c514b2dadd29ba5f6377f6fcfd229cc46a0.tar.bz2
gentoo-566e8c514b2dadd29ba5f6377f6fcfd229cc46a0.zip
dev-ml/pomap: bump to 3.0.6
Package-Manager: portage-2.3.0
-rw-r--r--dev-ml/pomap/Manifest1
-rw-r--r--dev-ml/pomap/pomap-3.0.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/pomap/Manifest b/dev-ml/pomap/Manifest
index 64268b7ea230..36c02d827016 100644
--- a/dev-ml/pomap/Manifest
+++ b/dev-ml/pomap/Manifest
@@ -1 +1,2 @@
DIST pomap-3.0.5.tar.gz 74574 SHA256 9788da1550dd88557262e91f4cd3f8c216b2b66ad0d3a2c7e65734177e5f87c2 SHA512 7b3700a7afd10dc0cbdc58086f27ed69b58b10776b6be9a268fa1a96f45f9af68c733f0939674325a415a55670875d1bb3d05ff562aa3ab9ae3a44822c13ddf4 WHIRLPOOL cc195567b7313ed20d6281fdfe775e2f9f6d5d58d2005a609505b5db18468d4885aa4e51608348d611e34961871d21de9935687667f9f8865c764f945ea39700
+DIST pomap-3.0.6.tar.gz 75345 SHA256 b9884487c1692d01de3c985894e06f820113f05d08f92909d817528b51e23f55 SHA512 c9b91b7eb3716f4ba735928bb7d33202fe4b05d3908afad36cffa01ffa5fa8f860b3a9d57a0b5bbf2577bb84f3a5b464ec85375e488a3fd5f8d99d7bbcf141a8 WHIRLPOOL b4edb268417d7dbeb31e972f81ba3d4669aac8a82645b24474e8db62b70402c5737402c690a2b69599da101021a99b2350728b03d1f76654008c42bb398966cc
diff --git a/dev-ml/pomap/pomap-3.0.6.ebuild b/dev-ml/pomap/pomap-3.0.6.ebuild
new file mode 100644
index 000000000000..f8b0cc700562
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pomap/"
+SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND="dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}