summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2016-11-21 07:56:08 +0900
committerAaron Bauman <bman@gentoo.org>2016-11-21 07:56:08 +0900
commit5693aae353fabcf5a12bca571dcc8e249dad1260 (patch)
treed51bdaacc5301e3c488f218fbd08fb94638a6002
parentdev-libs/json-c: drop vulnerable versions wrt security bug #507218 (diff)
downloadgentoo-5693aae353fabcf5a12bca571dcc8e249dad1260.tar.gz
gentoo-5693aae353fabcf5a12bca571dcc8e249dad1260.tar.bz2
gentoo-5693aae353fabcf5a12bca571dcc8e249dad1260.zip
dev-libs/json-c: drop remaining vulnerable versions wrt security bug #507218
-rw-r--r--dev-libs/json-c/Manifest1
-rw-r--r--dev-libs/json-c/json-c-0.11-r1.ebuild51
-rw-r--r--dev-libs/json-c/json-c-0.11.ebuild45
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-libs/json-c/Manifest b/dev-libs/json-c/Manifest
index 56df2580bf3e..ccbad493697f 100644
--- a/dev-libs/json-c/Manifest
+++ b/dev-libs/json-c/Manifest
@@ -1,2 +1 @@
-DIST json-c-0.11.tar.gz 557263 SHA256 28dfc65145dc0d4df1dfe7701ac173c4e5f9347176c8983edbfac9149494448c SHA512 65ab563fe908d585ba05fff3b77283050ec4f94114ff6e4b916557013d75498271cf65b2660a0aaf74b23beaa80385c80d37ab6a700ba967dd859fa779a81cb0 WHIRLPOOL f47c78b206a49a6e1d2570d041917593f3b889125b47a951ec1347f5c470082113225e86ff593869b5d859c2c815ceda268d4a3c890f53af77fae8dbbf7d97f8
DIST json-c-0.12.tar.gz 501419 SHA256 000c01b2b3f82dcb4261751eb71f1b084404fb7d6a282f06074d3c17078b9f3f SHA512 c959804362386f6b77e9d04b5fedf6d6aff1fcd0ab50250edb25f759b510b402e7ad4b33d1cbadc3337b63a3145d19f310812a9ee351748348304b384dc2dc35 WHIRLPOOL b49f5c96b614302b39737306774b4346d8347afef6ced7067664ac0d68669a1496fe915f229e0d434a87b103ac9982d67c5785eb688b7026c257c7eae95c6eaf
diff --git a/dev-libs/json-c/json-c-0.11-r1.ebuild b/dev-libs/json-c/json-c-0.11-r1.ebuild
deleted file mode 100644
index 8f732c804d7c..000000000000
--- a/dev-libs/json-c/json-c-0.11-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-multilib
-
-DESCRIPTION="A JSON implementation in C"
-HOMEPAGE="https://github.com/json-c/json-c/wiki"
-SRC_URI="https://s3.amazonaws.com/json-c_releases/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc static-libs"
-
-RDEPEND="
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20140406-r3
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-# tests break otherwise
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-src_prepare() {
- sed -i -e "s:-Werror::" Makefile.am.inc || die
- autotools-multilib_src_prepare
-}
-
-src_configure() {
- # Disable old lib compatibility
- myeconfargs=(--disable-oldname-compat)
- autotools-multilib_src_configure
-}
-
-src_test() {
- export USE_VALGRIND=0 VERBOSE=1
- autotools-multilib_src_test
-}
-
-src_install() {
- use doc && HTML_DOCS=( "${S}"/doc/html )
- autotools-multilib_src_install
-
- # add symlink for projects not using pkgconfig
- dosym ../json-c /usr/include/json-c/json
-}
diff --git a/dev-libs/json-c/json-c-0.11.ebuild b/dev-libs/json-c/json-c-0.11.ebuild
deleted file mode 100644
index 84b271c6ee19..000000000000
--- a/dev-libs/json-c/json-c-0.11.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
-
-DESCRIPTION="A JSON implementation in C"
-HOMEPAGE="https://github.com/json-c/json-c/wiki"
-SRC_URI="https://s3.amazonaws.com/json-c_releases/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc static-libs"
-
-# tests break otherwise
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-src_prepare() {
- sed -i -e "s:-Werror::" Makefile.am.inc || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # Disable old lib compatibility
- myeconfargs=(--disable-oldname-compat)
- autotools-utils_src_configure
-}
-
-src_test() {
- export USE_VALGRIND=0 VERBOSE=1
- autotools-utils_src_test
-}
-
-src_install() {
- use doc && HTML_DOCS=( "${S}"/doc/html )
- autotools-utils_src_install
-
- # add symlink for projects not using pkgconfig
- dosym ../json-c /usr/include/json-c/json
-}