summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-04-01 11:05:57 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-04-01 11:06:40 +0200
commit574bfbd15c8b8e304f436063069149eaaac5bbbd (patch)
treefc6f0d3876d71dbabfba356275a90666470fed42
parentdev-java/jgoodies-animation: EAPI 6 bump. (diff)
downloadgentoo-574bfbd15c8b8e304f436063069149eaaac5bbbd.tar.gz
gentoo-574bfbd15c8b8e304f436063069149eaaac5bbbd.tar.bz2
gentoo-574bfbd15c8b8e304f436063069149eaaac5bbbd.zip
dev-java/jgoodies-animation: clean up old.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-java/jgoodies-animation/Manifest1
-rw-r--r--dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild53
-rw-r--r--dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild62
3 files changed, 0 insertions, 116 deletions
diff --git a/dev-java/jgoodies-animation/Manifest b/dev-java/jgoodies-animation/Manifest
index a688a2ca5b6c..a3191f31ff45 100644
--- a/dev-java/jgoodies-animation/Manifest
+++ b/dev-java/jgoodies-animation/Manifest
@@ -1,2 +1 @@
-DIST animation-1_2_0.zip 728028 BLAKE2B 591b63b6a2799bfe6020c4e81b834807fba3e72a039dbd9954846b6c5a5c2445493e2d8814b1897b9465ec39c2b62c2f027c1e05ef7db5e9439acc236dbf9078 SHA512 2220630d7fd70a98b6d9605de7a1d6fc3470cc19b39815b9777e6bc8cf7db74ce77338861dde45aafbe336ce8b48ee00bcd8149af701a7001869cd3da3cf6a72
DIST jgoodies-animation-1.2.0.zip 728028 BLAKE2B 591b63b6a2799bfe6020c4e81b834807fba3e72a039dbd9954846b6c5a5c2445493e2d8814b1897b9465ec39c2b62c2f027c1e05ef7db5e9439acc236dbf9078 SHA512 2220630d7fd70a98b6d9605de7a1d6fc3470cc19b39815b9777e6bc8cf7db74ce77338861dde45aafbe336ce8b48ee00bcd8149af701a7001869cd3da3cf6a72
diff --git a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild
deleted file mode 100644
index 3a8392129d3e..000000000000
--- a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc examples source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_V=${PV//./_}
-
-DESCRIPTION="JGoodies Animation Library"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/animation-${MY_V}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4
- app-arch/unzip
- test? ( dev-java/ant-junit )"
-
-RDEPEND=">=virtual/jre-1.4
- examples? (
- >=dev-java/jgoodies-binding-1.1:1.0
- >=dev-java/jgoodies-forms-1.0:0
- )"
-
-S="${WORKDIR}/animation-${PV}"
-
-EANT_FILTER_COMPILER="jikes"
-EANT_DOC_TARGET=""
-
-java_prepare() {
- find -name "*.jar" -delete || die
-}
-
-src_test() {
- eant test -Djunit.jar.present=true \
- -Djunit.jar=$(java-pkg_getjar junit junit.jar)
-}
-
-src_install() {
- java-pkg_dojar build/animation.jar
-
- dodoc RELEASE-NOTES.txt || die
- dohtml README.html || die
- use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc src/core/*
- use examples && java-pkg_doexamples src/tutorial
-}
diff --git a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
deleted file mode 100644
index 6e12c6377096..000000000000
--- a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-JAVA_PKG_IUSE="doc examples source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_V=${PV//./_}
-DESCRIPTION="JGoodies Animation Library"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/animation-${MY_V}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4
- app-arch/unzip
- test? ( dev-java/ant-junit )"
-# Remove x86 when https://bugs.gentoo.org/show_bug.cgi?id=186081
-# is done
-RDEPEND=">=virtual/jre-1.4
- examples? ( x86? (
- >=dev-java/jgoodies-binding-1.1
- >=dev-java/jgoodies-forms-1.0
- ) )"
-
-S="${WORKDIR}/animation-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Remove the packaged jar
- rm -v lib/*.jar *.jar || die
-
- # cp ${FILESDIR}/build-${PV}.xml ${S}
- java-ant_xml-rewrite -f build.xml -d -e javac -a bootclasspath \
- || die "Failed to fix bootclasspath"
- java-pkg_filter-compiler jikes
-}
-
-# precompiled javadocs
-EANT_DOC_TARGET=""
-
-src_test() {
- eant test -Djunit.jar.present=true \
- -Djunit.jar=$(java-pkg_getjar junit junit.jar)
-}
-
-src_install() {
- java-pkg_dojar build/animation.jar
-
- dodoc RELEASE-NOTES.txt || die
- dohtml README.html || die
- use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc src/core/*
- use examples && java-pkg_doexamples src/tutorial
-}