summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-06-28 22:26:39 -0400
committerMike Gilbert <floppym@gentoo.org>2016-06-28 22:26:39 -0400
commit57c5991e03570071692d111a0f0fe36bd4946b9a (patch)
treee5401fccf157fbc9e6a142600954afcfcd670e6b
parentsys-boot/grub: refactor platform logic (diff)
downloadgentoo-57c5991e03570071692d111a0f0fe36bd4946b9a.tar.gz
gentoo-57c5991e03570071692d111a0f0fe36bd4946b9a.tar.bz2
gentoo-57c5991e03570071692d111a0f0fe36bd4946b9a.zip
Revert "sys-boot/grub: populate MULTIBUILD_VARIANTS in a more PMS-defined way"
This reverts commit e1374135af76bf31a01ff4ecb6696d8bbe041f31.
-rw-r--r--sys-boot/grub/grub-2.02_beta3-r1.ebuild15
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild15
2 files changed, 2 insertions, 28 deletions
diff --git a/sys-boot/grub/grub-2.02_beta3-r1.ebuild b/sys-boot/grub/grub-2.02_beta3-r1.ebuild
index 51efcb7db16d..edef1e750f30 100644
--- a/sys-boot/grub/grub-2.02_beta3-r1.ebuild
+++ b/sys-boot/grub/grub-2.02_beta3-r1.ebuild
@@ -219,19 +219,6 @@ grub_configure() {
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
-grub_get_platforms() {
- MULTIBUILD_VARIANTS=()
- local platform
- for platform in "${GRUB_ALL_PLATFORMS[@]}"; do
- if use "grub_platforms_${platform}"; then
- MULTIBUILD_VARIANTS+=( "${platform}" )
- fi
- done
- if (( ${#MULTIBUILD_VARIANTS[@]} == 0 )); then
- MULTIBUILD_VARIANTS=( guessed )
- fi
-}
-
src_configure() {
# Bug 508758.
replace-flags -O3 -O2
@@ -253,7 +240,7 @@ src_configure() {
tc-export BUILD_CC # Bug 485592
# Portage will take care of cleaning up GRUB_PLATFORMS
- grub_get_platforms
+ MULTIBUILD_VARIANTS=( ${GRUB_PLATFORMS:-guessed} )
grub_do grub_configure
}
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index ad5762439cbb..9fe3b54b1ad7 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -220,19 +220,6 @@ grub_configure() {
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
-grub_get_platforms() {
- MULTIBUILD_VARIANTS=()
- local platform
- for platform in "${GRUB_ALL_PLATFORMS[@]}"; do
- if use "grub_platforms_${platform}"; then
- MULTIBUILD_VARIANTS+=( "${platform}" )
- fi
- done
- if (( ${#MULTIBUILD_VARIANTS[@]} == 0 )); then
- MULTIBUILD_VARIANTS=( guessed )
- fi
-}
-
src_configure() {
# Bug 508758.
replace-flags -O3 -O2
@@ -254,7 +241,7 @@ src_configure() {
tc-export BUILD_CC # Bug 485592
# Portage will take care of cleaning up GRUB_PLATFORMS
- grub_get_platforms
+ MULTIBUILD_VARIANTS=( ${GRUB_PLATFORMS:-guessed} )
grub_do grub_configure
}