summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-10-08 18:04:47 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-10-08 18:07:10 -0400
commit57dbd4a0c591e4c1fe219d6883c54b5a19e6ac27 (patch)
tree6f2a1fcb400b0c0c0406fea7ed6b59bc1af532de
parentapp-office/grisbi: bump to 1.2.2 (diff)
downloadgentoo-57dbd4a0c591e4c1fe219d6883c54b5a19e6ac27.tar.gz
gentoo-57dbd4a0c591e4c1fe219d6883c54b5a19e6ac27.tar.bz2
gentoo-57dbd4a0c591e4c1fe219d6883c54b5a19e6ac27.zip
sci-mathematics/rw: new revision to fix the build.
No good deed goes unpunished! The recent version bump that contained only "minor build system and documentation fixes" broke the build. The upstream v0.8 tarball contains symlinks to various important files instead of the files themselves, and that doesn't always work. Instead, we now run eautoreconf in src_prepare() to (re)generate those files. Closes: https://bugs.gentoo.org/696986 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/rw/rw-0.8-r1.ebuild (renamed from sci-mathematics/rw/rw-0.8.ebuild)11
1 files changed, 11 insertions, 0 deletions
diff --git a/sci-mathematics/rw/rw-0.8.ebuild b/sci-mathematics/rw/rw-0.8-r1.ebuild
index 97ddc55d7a67..9a8731893982 100644
--- a/sci-mathematics/rw/rw-0.8.ebuild
+++ b/sci-mathematics/rw/rw-0.8-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Compute rank-width decompositions of graphs"
HOMEPAGE="https://sourceforge.net/projects/rankwidth/"
SRC_URI="https://downloads.sourceforge.net/project/rankwidth/${P}.tar.gz"
@@ -20,6 +22,15 @@ RDEPEND="${DEPEND}
DOCDIR="/usr/share/doc/${PF}"
+src_prepare() {
+ # The upstream tarball for v0.8 contains SYMLINKS to ar-lib,
+ # compile, install-sh, ltmain.sh, etc. And those symlinks don't
+ # always point to a working location for us, so we have to
+ # (re)generate actual files for that stuff. Bug 696986.
+ eautoreconf
+ default
+}
+
src_configure(){
econf $(use_enable executable) --docdir="${EPREFIX}${DOCDIR}"
}