summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2020-08-02 22:34:14 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-06 10:58:01 +0300
commit57fab5312662780f096ce127002b3ebbaf103b9f (patch)
tree5239ba2d63050a40bdb5657dc28937e1955745f0
parentnet-libs/libsearpc: add python3.{7,8,9} compatibility (diff)
downloadgentoo-57fab5312662780f096ce127002b3ebbaf103b9f.tar.gz
gentoo-57fab5312662780f096ce127002b3ebbaf103b9f.tar.bz2
gentoo-57fab5312662780f096ce127002b3ebbaf103b9f.zip
net-misc/seafile: version bump to 7.0.9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-misc/seafile/Manifest1
-rw-r--r--net-misc/seafile/seafile-7.0.9.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/seafile/Manifest b/net-misc/seafile/Manifest
index 70225e17d34f..53f705ae8730 100644
--- a/net-misc/seafile/Manifest
+++ b/net-misc/seafile/Manifest
@@ -1 +1,2 @@
DIST seafile-7.0.5.tar.gz 706430 BLAKE2B 49402de13660bcda9a6fad35879bd0e9ba4e491e921525a9cb16498f833d0d8e4177e615afa95780da040c9617d2795a3aa97ce389edae54621d8079033fd24e SHA512 c51c5f3f4a4b316fdf21d8eec12d42e7e1c76cf1271393658dd447c4b0ba77e6149eb7770a99af6aa23f6ebcb1572f4b847f8de44320d8bae8960bde7f429920
+DIST seafile-7.0.9.tar.gz 706859 BLAKE2B 2cbd12bfdda9c2cc13d38233a56d0d2f52ad04e03bd14c90c6ff086756fb7ab4f63319906030f9a5f4ec2625dbe23b2892c069f2b5d50c6997b23deaf2cb61d7 SHA512 4c87e7a4a6a4cef631cbfbeb1bde3c8c9e0915d5fe4597d5b3a4b8aa15e9650e97b51ee6a3b0bae4d235ec53149dca01aed7acd704da593c97da0a17e352a75d
diff --git a/net-misc/seafile/seafile-7.0.9.ebuild b/net-misc/seafile/seafile-7.0.9.ebuild
new file mode 100644
index 000000000000..e5d55487b0ad
--- /dev/null
+++ b/net-misc/seafile/seafile-7.0.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8,9})
+
+WANT_AUTOMAKE=1.16
+
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/glib:2
+ dev-libs/libevent
+ dev-libs/jansson
+ sys-libs/zlib
+ net-misc/curl
+ !libressl? ( dev-libs/openssl )
+ libressl? ( dev-libs/libressl )
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+ python_fix_shebang "${ED}"/usr/bin
+}