summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-06-14 01:20:05 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-06-14 01:32:13 -0500
commit58623b30247c1711f0331fb8a19996bfb38f0b6e (patch)
tree75bbb69b94abf4a4f36e218fdc7b816bce86152f
parentapp-emulation/libvirt: bump to version 1.3.5 (diff)
downloadgentoo-58623b30247c1711f0331fb8a19996bfb38f0b6e.tar.gz
gentoo-58623b30247c1711f0331fb8a19996bfb38f0b6e.tar.bz2
gentoo-58623b30247c1711f0331fb8a19996bfb38f0b6e.zip
dev-python/libvirt-python: bump to version 1.3.5
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.3.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 3532b8984a9b..e5718e0fc18b 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,3 +1,4 @@
DIST libvirt-python-1.2.21.tar.gz 171250 SHA256 7ffb49fcb64ac06188fc626c853c99361e5965766ab020f8ea66f8fbcfc29684 SHA512 7e2481ffa26105ddde703bd6eafe74240b69990b2f2ce0042f20f7fceb1d326fb8a66bf26042bfe63a12cf3202d7c19b14b6d766dd42fb66af212393d7aaf332 WHIRLPOOL 18dd5bc0d565b6846c40960cf258d7fb3714054be15fe54507e2846c5a7c2cd81e9b209c8e70cbfd5319d5a06f00c2c5322995058637af87d1676276f8675b2e
DIST libvirt-python-1.3.1.tar.gz 171221 SHA256 7143b922a9bd66a5e199b13316fa4266cbffc23db01c99bce37216a1eb9118f7 SHA512 f980d6aec1c83422d01c8ff02915357f4903f8c2a8ea9538da35e7313f6d491ebb4646e642097269a6be2996da879e7594c5e166cf2cc0bd96745eace7ce7567 WHIRLPOOL 3fe0ecba5f618eab1059c5e4ac4ef8789ed6684f36aee336f2e366198805560706c41d67ddceb328a0ad66867145a103aa15665b646b7bc5a5b058b02755ce11
DIST libvirt-python-1.3.4.tar.gz 172808 SHA256 badd2f51b07d5b03be7c01c45d8f52fea181ba9386ced5b12241ffdcf7e4f7a7 SHA512 18063021edf28b6c7b6b407590ec94eda45272c6b976ef560b4e81a8b212a5c7d2c1ce844e066855cda0a1bca4e98028936314c58e12261952783bd606501f59 WHIRLPOOL 73e2a9a1327efad4e448bb08814ddbe5c8958bcdbe596ea539be39e3a34ff9ffed141aac40bd90d4c0b841e1ddd42f6d7905245499efa774dca6f99c16305814
+DIST libvirt-python-1.3.5.tar.gz 168780 SHA256 a0508a57637fd18a3584fb9d2322fb172f65708c9db16e0438a70eb0f36fa5c2 SHA512 e1241e71dc0c574b14c6ecb101ec611f0c8caab6a5f82268882febb7b1382752d350ee0f6c2d648c30c6af3f19ef5b91bb518d8a0bd6ab967807b82dd4cf893f WHIRLPOOL 83a861fd425320214c43b80053444cc273c761e88b2530a10d2e8bfe898b19e1563d9f3b182deabe7fc8a7f445c303fa495123bb28d41caa88954cceff40c453
diff --git a/dev-python/libvirt-python/libvirt-python-1.3.5.ebuild b/dev-python/libvirt-python/libvirt-python-1.3.5.ebuild
new file mode 100644
index 000000000000..cc59d1ba63b0
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-1.3.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}