summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 19:34:41 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:15:41 +0200
commit58646bc05dc1086028ce88ed4a50415473512eb7 (patch)
treee02670c200ed520f70109e0256008f0a6ab5ecd6
parentx11-plugins/wmmemload: EAPI7, improve ebuild (diff)
downloadgentoo-58646bc05dc1086028ce88ed4a50415473512eb7.tar.gz
gentoo-58646bc05dc1086028ce88ed4a50415473512eb7.tar.bz2
gentoo-58646bc05dc1086028ce88ed4a50415473512eb7.zip
x11-plugins/wmmisc: EAPI7, improve ebuild
-rw-r--r--x11-plugins/wmmisc/files/wmmisc-1.1-build.patch8
-rw-r--r--x11-plugins/wmmisc/wmmisc-1.1-r1.ebuild34
2 files changed, 38 insertions, 4 deletions
diff --git a/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch b/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch
index d42400ab0132..28979642dcbb 100644
--- a/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch
+++ b/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch
@@ -1,6 +1,6 @@
diff -ur wmmisc-1.1.orig/src/general.mk wmmisc-1.1/src/general.mk
---- wmmisc-1.1.orig/src/general.mk 2006-01-07 19:50:31.000000000 +0200
-+++ wmmisc-1.1/src/general.mk 2008-01-16 20:44:59.000000000 +0200
+--- a/general.mk 2006-01-07 19:50:31.000000000 +0200
++++ b/general.mk 2008-01-16 20:44:59.000000000 +0200
@@ -16,7 +16,7 @@
MANDIR = $(PREFIX)/share/man
# Set some destination locations.
@@ -35,8 +35,8 @@ diff -ur wmmisc-1.1.orig/src/general.mk wmmisc-1.1/src/general.mk
INCLUDES += -I.
# Set the include locations.
diff -ur wmmisc-1.1.orig/src/Makefile wmmisc-1.1/src/Makefile
---- wmmisc-1.1.orig/src/Makefile 2006-01-07 20:45:59.000000000 +0200
-+++ wmmisc-1.1/src/Makefile 2008-01-16 20:43:31.000000000 +0200
+--- a/Makefile 2006-01-07 20:45:59.000000000 +0200
++++ b/Makefile 2008-01-16 20:43:31.000000000 +0200
@@ -23,7 +23,7 @@
$(package): $(objects)
diff --git a/x11-plugins/wmmisc/wmmisc-1.1-r1.ebuild b/x11-plugins/wmmisc/wmmisc-1.1-r1.ebuild
new file mode 100644
index 000000000000..dfcf13a8c09e
--- /dev/null
+++ b/x11-plugins/wmmisc/wmmisc-1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a monitoring dockapp for system load, user amount, fork amount and processes"
+HOMEPAGE="https://packages.qa.debian.org/w/wmmisc.html"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${P}/src"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ../{ChangeLog,README}
+}