summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-07 10:04:49 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-07 10:04:49 +0200
commit58d1c22092ded71aeadd25152f8a896a479812b3 (patch)
tree6c676b160213296c18ba03835c42e14c821b0e10
parentnet-dns/nsd: Security cleanup (diff)
downloadgentoo-58d1c22092ded71aeadd25152f8a896a479812b3.tar.gz
gentoo-58d1c22092ded71aeadd25152f8a896a479812b3.tar.bz2
gentoo-58d1c22092ded71aeadd25152f8a896a479812b3.zip
app-emulation/x48: Use readline:0 package
* x48 was using an incorrect SLOT dependency Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-emulation/x48/x48-0.6.4-r2.ebuild (renamed from app-emulation/x48/x48-0.6.4-r1.ebuild)13
1 files changed, 7 insertions, 6 deletions
diff --git a/app-emulation/x48/x48-0.6.4-r1.ebuild b/app-emulation/x48/x48-0.6.4-r2.ebuild
index 25255dc0248c..60123e66d5ad 100644
--- a/app-emulation/x48/x48-0.6.4-r1.ebuild
+++ b/app-emulation/x48/x48-0.6.4-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -14,9 +14,10 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
IUSE="readline"
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
- readline? ( sys-libs/readline:5 )"
+ readline? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
x11-libs/libXt"
@@ -28,7 +29,7 @@ src_unpack() {
}
src_prepare() {
- eapply_user
+ default
sed -i '698s/inline/static inline/' src/emulate.c || die
eautoreconf
}
@@ -38,10 +39,10 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
+
insinto /usr/share/"${PN}"/romdump
doins -r romdump/{README,ROMDump*}
- dodoc AUTHORS README ChangeLog
}
pkg_postinst() {