summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 22:56:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 23:18:11 +0200
commit58ece3835d05250df35c2466a1794467e014ec7b (patch)
treeb588591645b38fcac9532638aaec07ad4accad1c
parentdev-python/python-xlib: Bump to 0.30 (diff)
downloadgentoo-58ece3835d05250df35c2466a1794467e014ec7b.tar.gz
gentoo-58ece3835d05250df35c2466a1794467e014ec7b.tar.bz2
gentoo-58ece3835d05250df35c2466a1794467e014ec7b.zip
dev-python/pytest-django: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-4.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 27c428d2be32..ab2a0a1dc9ea 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,2 +1,3 @@
DIST pytest-django-4.1.0.gh.tar.gz 67983 BLAKE2B b7f4fe1366ce1443b19f05e8e834f0555cd8d63bf10921be1427338b7e5e737b7e04d96c9c9d2ad1b9c0f0ed6fba4ed93fb4fd9a948dc5315b4b7a35ba8adfd1 SHA512 734921f5c6f8569f6488706fbb6ca2515a5b24c6641fd260771022bd4fd72b65d062a8130f59163e8b30f4c9bceb383d154b26f8fbf46a1903339668d0a7d12b
DIST pytest-django-4.2.0.gh.tar.gz 68370 BLAKE2B 94165a01ecd2734a4e02267ecfe8b531df33ca9237cfcd1ebad41f68289fb89590bed0027137d6dddefc4cbbd5c0f8445703e01a516d3992c2307ebe53d6572b SHA512 2dcaa80f3ebb67984d3849cea5de296388990ca65a607f995b89bd67e2d8964f944100bccb42a32bb75c7009849619e50421c2dce077037ce0440233dbdc13f1
+DIST pytest-django-4.3.0.gh.tar.gz 71525 BLAKE2B 0eba9d9917759369aa2e126539f17fc36874453caf59838be2baf660fe29487aa80490f2af4ecbd72a9ba1f63a8a87202af2eff7e9d28c9c0fc686b09b07e82a SHA512 3c3ac31ed75daa29ab473ef3b87b5c66333cf7ccd8d217eb120b7899f463aafe5982b1e867e26e3b9ab51f312612fbc3d9f1ed9169815507816267fd4de76757
diff --git a/dev-python/pytest-django/pytest-django-4.3.0.ebuild b/dev-python/pytest-django/pytest-django-4.3.0.ebuild
new file mode 100644
index 000000000000..ac4f7fbd41ae
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}