summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-01 11:29:01 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-02 00:40:30 +0100
commit58fc0e34366119192a59c1993a4fcfc75a9bafca (patch)
tree20668ce0c0bc5e1de44d99cfa3e5a0d891ca05f6
parentsys-devel/clang: Bump to 5.0.1_rc2 (diff)
downloadgentoo-58fc0e34366119192a59c1993a4fcfc75a9bafca.tar.gz
gentoo-58fc0e34366119192a59c1993a4fcfc75a9bafca.tar.bz2
gentoo-58fc0e34366119192a59c1993a4fcfc75a9bafca.zip
dev-python/clang-python: Bump to 5.0.1_rc2
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-5.0.1_rc2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index 4d92e834aa52..76edcde2e379 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -1,2 +1,3 @@
DIST cfe-4.0.1.src.tar.xz 10933628 SHA256 61738a735852c23c3bdbe52d035488cdb2083013f384d67c1ba36fabebd8769b SHA512 936c9e1626b27e63a4fb11f3c0cb998eeaf9a520ad6e2bcd67cb4352e59e7781ecc700df79794f3fd70473d90b7e2ba418a39038eb0146b68e843f0705c1f964 WHIRLPOOL 1cb56b36e21eab8004eec43d9c0f7377588cdbcd1d654cd0e6d836d43bc68dc0759993215439c1607e09ed3fa1f68b80504a222f73c1b76d3841cdf638dcbef2
DIST cfe-5.0.0.src.tar.xz 11437024 SHA256 019f23c2192df793ac746595e94a403908749f8e0c484b403476d2611dd20970 SHA512 14acdd622310122b544c952ee5b932b7006d9d8424319f0e3974f2503d40a0cec4200fdd3d813a32ce0d877bcfbb9a5bd5c36f6142b4330e6c814f113ca2efe8 WHIRLPOOL 9d2fff35324621be191cc69b45db472681c9ebdf05aead09510f3178853ac8a179f2c454c2e6513e57f84a99980052671cd9a23d38d6d14b42dfda1853a7844a
+DIST cfe-5.0.1rc2.src.tar.xz 11512960 BLAKE2B f6f53a985abfc07869984a8b6461549df80d8511645ff0ba46c035b04f247d9f56a63a178da7496b60064aed059518175d2d34aa661b72877f3e62b27c9eed13 SHA512 069fa3dc549ed046a004ca31a1e571fe83fca986635b5515e9eab3f91e3a962af99022e927d15fa2482969c64fa9b33c9c7e79a8cd9dd8fa77b554ba3f08d1ea
diff --git a/dev-python/clang-python/clang-python-5.0.1_rc2.ebuild b/dev-python/clang-python/clang-python-5.0.1_rc2.ebuild
new file mode 100644
index 000000000000..97dd5ec33bf1
--- /dev/null
+++ b/dev-python/clang-python/clang-python-5.0.1_rc2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="http://prereleases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}/bindings/python
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
+}
+
+src_test() {
+ python_foreach_impl nosetests -v || die
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}