summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2017-07-31 12:34:48 +0200
committerSlawomir Lis <slis@gentoo.org>2017-07-31 12:34:48 +0200
commit59c4ef46f3b098ec5fb71ac02c329dd9fb810011 (patch)
tree13fda293643f980bcc9cfdc35d96115d59000322
parentdev-python/pysolr-3.3.2-r0: amd64 stable (diff)
downloadgentoo-59c4ef46f3b098ec5fb71ac02c329dd9fb810011.tar.gz
gentoo-59c4ef46f3b098ec5fb71ac02c329dd9fb810011.tar.bz2
gentoo-59c4ef46f3b098ec5fb71ac02c329dd9fb810011.zip
dev-python/Kivy: version bump tp 1.10.0
Also should fix problems with cython (bug 626588) Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/Kivy/Kivy-1.10.0.ebuild71
-rw-r--r--dev-python/Kivy/Manifest1
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/Kivy/Kivy-1.10.0.ebuild b/dev-python/Kivy/Kivy-1.10.0.ebuild
new file mode 100644
index 000000000000..8e2cb32ef0b7
--- /dev/null
+++ b/dev-python/Kivy/Kivy-1.10.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DESCRIPTION="Library for rapid development of hardware-accelerated multitouch applications"
+HOMEPAGE="http://kivy.org/"
+SRC_URI="https://github.com/kivy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo camera doc examples garden gstreamer +sdl spell test"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
+ camera? ( media-libs/opencv:0/2.4[$(python_gen_usedep 'python2_7')] )
+ garden? ( dev-python/kivy-garden[${PYTHON_USEDEP}] )
+ gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )
+ sdl? ( media-libs/libsdl2
+ media-libs/sdl2-ttf
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer )
+ !sdl? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P,,}"
+
+python_prepare_all() {
+# sed -e '/data_files=/d' -i "${S}/setup.py" || die
+# sed -e 's/PYTHON = python/PYTHON ?= python/' -i Makefile || die
+
+ export USE_SDL2=$(usex sdl 1 0)
+ export USE_GSTREAMER=$(usex gstreamer 1 0)
+ export KIVY_USE_SETUPTOOLS=1
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ esetup.py build_ext --inplace
+ esetup.py build
+}
+
+python_compile_all() {
+ use doc && emake html
+}
+
+python_test() {
+ emake test PYTHON="${PYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples/${f}/"
+ doins "${S}/examples"/* "${S}/examples"/*/*
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Kivy/Manifest b/dev-python/Kivy/Manifest
index 5a1d1bf21dd5..93c563f20046 100644
--- a/dev-python/Kivy/Manifest
+++ b/dev-python/Kivy/Manifest
@@ -1 +1,2 @@
+DIST Kivy-1.10.0.tar.gz 24266702 SHA256 ca925bf29dc9d2324f00ceb0727fafd7796c369e7dba2ae13c1c9001ae8ea7d4 SHA512 8049c92407e464558ecff913ff076c1b8f125b85a35b9eba64af49b35df545402ec2bac907ee545265a368b8cdbb33e02d74429dce13c53dd6feac735ace9cb4 WHIRLPOOL 6edb4d9d3cd83d5823268ecf2836e02b69be96e04d951a2b3b3f38abe2e4fab0fa1ae4804ccfc6673db7222f3d813e0cca35101cf7b1d091c2c5e060df42c83e
DIST kivy-1.9.1.tar.gz 16363833 SHA256 29bc45be34c26a8acb1dafdd329145f997a473be344cd052659f821f6478637e SHA512 1ae3ff3979a89e41c0af6493b7523835c1d01ee36fcd524f15d329b8fa875c6ca9bd25db3a844597fbc5370ff86b55ce177d3e66cc169223b02eb114c88c9989 WHIRLPOOL f2eebf64f3abc2b63d307d8aadc87d0beb980e9bf5f85ff664e973b5c014ccb4f3fed58d24e2ca1e416e959ece1c094e34c0d75630003c89ab3a36237137042d