summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-03-31 23:42:04 +0400
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-26 22:08:26 +0300
commit5a62c61bc94f482d303b5c7e5fa3cd27cc09d6bb (patch)
tree6eb0df69987070dd209dd8e80fb97abf6b0cd7e2
parentapp-doc/python-docs: Stabilize 3.11.9 x86, #929046 (diff)
downloadgentoo-5a62c61bc94f482d303b5c7e5fa3cd27cc09d6bb.tar.gz
gentoo-5a62c61bc94f482d303b5c7e5fa3cd27cc09d6bb.tar.bz2
gentoo-5a62c61bc94f482d303b5c7e5fa3cd27cc09d6bb.zip
net-print/npadmin: fix configure error on Clang/GCC-14
Bundled configure used bad compiler check script. Running autoreconf fixed that problem. Makefile.in contained old name of configure.in, fixed that in patch EAPI bump and revbump included as now npadmin may pull new compile flags Closes: https://bugs.gentoo.org/875749 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/35964 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--net-print/npadmin/files/npadmin-0.8.7-makefile.patch43
-rw-r--r--net-print/npadmin/npadmin-0.8.7-r2.ebuild34
2 files changed, 77 insertions, 0 deletions
diff --git a/net-print/npadmin/files/npadmin-0.8.7-makefile.patch b/net-print/npadmin/files/npadmin-0.8.7-makefile.patch
new file mode 100644
index 000000000000..140750a0b0b8
--- /dev/null
+++ b/net-print/npadmin/files/npadmin-0.8.7-makefile.patch
@@ -0,0 +1,43 @@
+--- a/Makefile.in 2024-03-28 13:35:04.247099098 +0000
++++ b/Makefile.in 2024-03-28 13:33:44.610623716 +0000
+@@ -104,7 +104,7 @@
+ NROFF = nroff
+ DIST_COMMON = README ./stamp-h.in AUTHORS COPYING ChangeLog INSTALL \
+ Makefile.am Makefile.in NEWS TODO acconfig.h aclocal.m4 config.h.in \
+-configure configure.in install-sh memcmp.c missing mkinstalldirs \
++configure configure.ac install-sh memcmp.c missing mkinstalldirs \
+ npadmin.spec.in snprintf.c
+
+
+@@ -118,19 +118,19 @@
+ all: all-redirect
+ .SUFFIXES:
+ .SUFFIXES: .C .S .c .o .s
+-$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
++$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.ac $(ACLOCAL_M4)
+ cd $(top_srcdir) && $(AUTOMAKE) --gnu --include-deps Makefile
+
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+-$(ACLOCAL_M4): configure.in
++$(ACLOCAL_M4): configure.ac
+ cd $(srcdir) && $(ACLOCAL)
+
+ config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+ $(SHELL) ./config.status --recheck
+-$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
++$(srcdir)/configure: $(srcdir)/configure.ac $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
+ cd $(srcdir) && $(AUTOCONF)
+
+ config.h: stamp-h
+@@ -148,7 +148,7 @@
+ rm -f $(srcdir)/stamp-h.in; \
+ $(MAKE) $(srcdir)/stamp-h.in; \
+ else :; fi
+-$(srcdir)/stamp-h.in: $(top_srcdir)/configure.in $(ACLOCAL_M4) acconfig.h
++$(srcdir)/stamp-h.in: $(top_srcdir)/configure.ac $(ACLOCAL_M4) acconfig.h
+ cd $(top_srcdir) && $(AUTOHEADER)
+ @echo timestamp > $(srcdir)/stamp-h.in 2> /dev/null
+
diff --git a/net-print/npadmin/npadmin-0.8.7-r2.ebuild b/net-print/npadmin/npadmin-0.8.7-r2.ebuild
new file mode 100644
index 000000000000..fa6d1bf147cd
--- /dev/null
+++ b/net-print/npadmin/npadmin-0.8.7-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Network printer command-line administration tool"
+HOMEPAGE="https://npadmin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# this does NOT link against SNMP
+# DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-stdlib.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin npadmin
+ doman npadmin.1
+ dodoc README AUTHORS ChangeLog INSTALL NEWS README TODO
+}