summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-04-10 02:26:22 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-04-10 02:26:22 +0200
commit5ae0aea7fe50cf9217903949e1fd794b67535889 (patch)
tree90820b4b9e4b23f1b88a816a4eedb8c54327f41b
parentx11-drivers/xf86-input-libinput: Version bump to 0.27.1 (diff)
downloadgentoo-5ae0aea7fe50cf9217903949e1fd794b67535889.tar.gz
gentoo-5ae0aea7fe50cf9217903949e1fd794b67535889.tar.bz2
gentoo-5ae0aea7fe50cf9217903949e1fd794b67535889.zip
app-text/editorconfig-core-c: Version bump to 0.12.2
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--app-text/editorconfig-core-c/Manifest1
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/editorconfig-core-c/Manifest b/app-text/editorconfig-core-c/Manifest
index f70adae767ad..2433f69490a5 100644
--- a/app-text/editorconfig-core-c/Manifest
+++ b/app-text/editorconfig-core-c/Manifest
@@ -1 +1,2 @@
DIST editorconfig-core-c-0.12.1.tar.gz 65369 BLAKE2B 30296b64bd215a8b51d3b4d6146ce5eac13cb1a8ba8a25d0faabcc22989503d9d73bc138240b475eb7ea4eecd5f5bbbf347519b1696373daf55ffd27fc772f4c SHA512 3517f7db84d632615ba651eeafab6730739b7bf01f4ea34fbca65f58463fbbcbabc101587b289a7922b55708453262c65569077c51087424d47d0676dc1db686
+DIST editorconfig-core-c-0.12.2.tar.gz 67002 BLAKE2B 6b808366acc8d0a96fc47cb74d620a4028978d7114b4a64d6799527276442f1d39ba8d5611530f873c78b7c49893c5edecec84dcc6f2616ba2663cb36fa92d0d SHA512 6ab3e4f7f95c83c0781064ca15bb70394bb947f9d4cd1348224f02e25c65021d14439b913775d7cfafb93476158799c34438fa548adf3c7ec6dbfd6f1052a046
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild
new file mode 100644
index 000000000000..1bfe84ca069f
--- /dev/null
+++ b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="EditorConfig core library written in C"
+HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
+SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="cli doc"
+CDEPEND="dev-libs/libpcre:="
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}
+ cli? ( !dev-python/editorconfig-core-py[cli] )"
+
+src_prepare() {
+ sed -e 's:OUTPUT_NAME editorconfig_static:OUTPUT_NAME editorconfig:' \
+ -i src/lib/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=()
+ use doc && mycmakeargs+=(-DINSTALL_HTML_DOC=ON)
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use cli || rm -rf "${ED}usr/bin"
+}