summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-25 21:06:34 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-25 21:07:19 +1200
commit5af56a7c9fb7a22ebe38fa36cf93684580667048 (patch)
treece4ec7940704788825b25f09c4323f434cb3438d
parentdev-ruby/childprocess: remove unused patch(es) (diff)
downloadgentoo-5af56a7c9fb7a22ebe38fa36cf93684580667048.tar.gz
gentoo-5af56a7c9fb7a22ebe38fa36cf93684580667048.tar.bz2
gentoo-5af56a7c9fb7a22ebe38fa36cf93684580667048.zip
dev-perl/DateTime: Bump to version 1.520.0
- EAPI7 - Ensure CFLAGS passed to compiler Upstream: - Add methods ->{month,quarter,year}_length() - Fixed formatting of CLDR "S" to truncate instead of rounding up to one. - Duration->multiply() now only allows integer multipliers - Add methods ->is_last_day_of{quarter,year} - Fix bad temporary state of duration after internal exceptions - Fix compile on 5.27.11 - Add method dt->is_between($a,$b) - Simplify XS calculation of leap seconds Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/DateTime/DateTime-1.520.0.ebuild52
-rw-r--r--dev-perl/DateTime/Manifest1
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-perl/DateTime/DateTime-1.520.0.ebuild b/dev-perl/DateTime/DateTime-1.520.0.ebuild
new file mode 100644
index 000000000000..ae06828db4a1
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.520.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.52
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CONFLICTS="
+ !<=dev-perl/DateTime-Format-Mail-0.402.0
+"
+RDEPEND="
+ ${CONFLICTS}
+ virtual/perl-Carp
+ >=dev-perl/DateTime-Locale-1.60.0
+ >=dev-perl/DateTime-TimeZone-2.20.0
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ >=dev-perl/Params-ValidationCompiler-0.260.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Specio-0.180.0
+ dev-perl/Try-Tiny
+ virtual/perl-XSLoader
+ >=dev-perl/namespace-autoclean-0.190.0
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-CPAN-Meta-Requirements
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/DateTime/Manifest b/dev-perl/DateTime/Manifest
index cea732c4b5b5..67e0588f6e05 100644
--- a/dev-perl/DateTime/Manifest
+++ b/dev-perl/DateTime/Manifest
@@ -4,3 +4,4 @@ DIST DateTime-1.28.tar.gz 229774 BLAKE2B a23b6f0bb990b84e1d045efb7ff8098e531d9d2
DIST DateTime-1.36.tar.gz 235407 BLAKE2B a6e710454df7cfc3e94487e663b746605f5a010893d878ae7d7406057ea557f1cff08dfd332207ab7a4c71a508942dd2dd63ed721d047c6c56c94197c9aeca49 SHA512 debb3c10f55d4dca66a495a89ac92f6a1f90c0091b6c223391f0e5d8835a6b5ef00e9529ac29f837e4e82baf630b82e3fcab20223e13ccaf4db9e9d08573486c
DIST DateTime-1.42.tar.gz 239033 BLAKE2B fd4c20c30d7008cd70dfbd020fff3a0a90f9ea1d5ae7cc71cf01f82aaa07e55b3bfd62eebf5f37cef91857b5aa93f5851bcba4a5b0bcbf63232285fbbabdc842 SHA512 79471a7b2f1bed829e2e767ee1d9d9bddbb9cf68205d008ff70c1002dd402f9dbee98834431d5319e4b8dd22abda29df85c81a32905df18d1ab78f1d05753505
DIST DateTime-1.44.tar.gz 239685 BLAKE2B 6d725244f1ef028a5860774b93c1e361e6cd14f6d6cff5a586ee8af6bd4c2fbb196b66884ec62878dbf585824d24e754092750e32cfaa57dc999307e4637e279 SHA512 a256efc26ad1f2859f3371b70e5edd0d962d2c19c54b746178e3945b1dc665621d09b7ac6be279c7e92b8aa91763c5df2d8ccbca1832ba69ac810feb8533ca71
+DIST DateTime-1.52.tar.gz 269535 BLAKE2B b8da6a8ca968fcceafed77465b7b25acf9a3438d0e8bbb209141d9a85eab415da54a874981ebcb1cfdac6a3e4edb1a617a1d4d45b58ece5a5ea8b6693aa0aec2 SHA512 c2e359f480396e0da16afbec362cb744f201f6c777fa916228f0adfd26a848b9451535feeda4e1531e5afb40a286e3b11a44e95dc0947dc4e2ba714973bb5ac4