summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-01 01:14:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-07 23:59:55 +0100
commit5b4f0996e4aa19d825106112ef187d0b7cfd9b88 (patch)
tree577b780ec118066e756aee77a8d0a16071007d0f
parentnet-wireless/gr-paint: EAPI-7 bump (diff)
downloadgentoo-5b4f0996e4aa19d825106112ef187d0b7cfd9b88.tar.gz
gentoo-5b4f0996e4aa19d825106112ef187d0b7cfd9b88.tar.bz2
gentoo-5b4f0996e4aa19d825106112ef187d0b7cfd9b88.zip
net-wireless/gr-rftap: EAPI-7 bump, missing cmake-utils_src_prepare
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-wireless/gr-rftap/gr-rftap-9999.ebuild42
1 files changed, 22 insertions, 20 deletions
diff --git a/net-wireless/gr-rftap/gr-rftap-9999.ebuild b/net-wireless/gr-rftap/gr-rftap-9999.ebuild
index e0f9dc95c130..621dada2edb8 100644
--- a/net-wireless/gr-rftap/gr-rftap-9999.ebuild
+++ b/net-wireless/gr-rftap/gr-rftap-9999.ebuild
@@ -1,44 +1,46 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
+EAPI=7
-DESCRIPTION="RFtap Module for GNU Radio"
-HOMEPAGE="https://github.com/rftap/gr-rftap"
+PYTHON_COMPAT=( python2_7 )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/rftap/gr-rftap.git"
+else
KEYWORDS=""
-#else
-# SRC_URI=""
-# KEYWORDS=""
fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="RFtap Module for GNU Radio"
+HOMEPAGE="https://github.com/rftap/gr-rftap"
LICENSE="GPL-3"
SLOT="0/${PV}"
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- dev-lang/swig:0"
+ >=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig:0
+"
#cppunit is listed in cmake, but only needed for tests and there are no tests
# dev-util/cppunit"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
src_prepare() {
+ cmake-utils_src_prepare
#although cppunit is not used, it fails if it isn't there, fix it
- sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
- sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
- sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt || die
}
src_configure() {
- mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ local mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
cmake-utils_src_configure
}