summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2015-08-28 16:28:51 -0400
committerIan Stakenvicius <axs@gentoo.org>2015-08-28 16:34:57 -0400
commit5b68706a43106a106e13c8fa3431c3bcb2b0ef32 (patch)
tree1be1e487b7d64eca9b4b019c1cd5868e5e4716c7
parentdev-libs/nss: version bump (diff)
downloadgentoo-5b68706a43106a106e13c8fa3431c3bcb2b0ef32.tar.gz
gentoo-5b68706a43106a106e13c8fa3431c3bcb2b0ef32.tar.bz2
gentoo-5b68706a43106a106e13c8fa3431c3bcb2b0ef32.zip
media-gfx/freewrl: version bump, add missing deps to live ebuild
Package-Manager: portage-2.2.20.1
-rw-r--r--media-gfx/freewrl/Manifest1
-rw-r--r--media-gfx/freewrl/freewrl-3.0.0.ebuild145
-rw-r--r--media-gfx/freewrl/freewrl-9999.ebuild21
3 files changed, 157 insertions, 10 deletions
diff --git a/media-gfx/freewrl/Manifest b/media-gfx/freewrl/Manifest
index 80dab2c5b08c..8cb009eead52 100644
--- a/media-gfx/freewrl/Manifest
+++ b/media-gfx/freewrl/Manifest
@@ -1,2 +1,3 @@
DIST freewrl-1.22.13.1.tar.bz2 1830305 SHA256 29069d63604dbbfde0f684f342f34e9d0eb216a026f83317a00fbdd31ece17e8 SHA512 6e751835a256ce08d4099e5301c0702e28e5cae2e77d8a51ab38f6f0c08680f22a9ef25ef9d2bb860680fc8c1fc22cfebf14cfb14b50ee514b5ef76e71ab1192 WHIRLPOOL 58d301f4f3c1d145b041bb626c8af18954d9cd3da88f348d2341928c2ff050b15e077855b1ef5a2fe18b2218b8d2f8a75e229ca5bf5d683c0c98e4ed132f71cd
DIST freewrl-2.3.3.1.tar.gz 1731651 SHA256 71ed11f5f3b4b6a1d2fc740e8e3ed62a83b484c9695968fac5e30db14dbb6fef SHA512 e205e8d11a3650ddf4f7dd089bdca36fc1879424c88392229ca8c0d532ebc4662f4f2e3bc491a0a1d6300e78c55cebbb57eeef2145a8c96c727c35dfb2a7d00a WHIRLPOOL d61f65b9f0db94f73760d6b1800be5f77f9898e2305ec93cc43aa8a8631e5d002602a1b79bbec91d30a040479ae01530cb470cb411d803ff8f04c3792e35e545
+DIST freewrl-3.0.0.tar.bz2 1567282 SHA256 91ab2e8fda840c2d52951f9833fe280080fab8eabd725dcccae1a9f3506c3ceb SHA512 12e75c6891238fbc9c750a9449c8a6a9f4b86124ac12871adbfb3c68b7ef09f35d3709dcb63693e50f8ac824170aef3b97854a72de0b324e67fbbb7c081675a0 WHIRLPOOL 78734eaa5f5cd7d3dd6bb6c7dff5621ecee2d5aba9f6fc1ce0cdbc851bdf2f58bb4f6416f0e7ad2fbb04122dda4687a2764f46819b83217951e8d1207b88c0f7
diff --git a/media-gfx/freewrl/freewrl-3.0.0.ebuild b/media-gfx/freewrl/freewrl-3.0.0.ebuild
new file mode 100644
index 000000000000..b2efb486f8fb
--- /dev/null
+++ b/media-gfx/freewrl/freewrl-3.0.0.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools nsplugins eutils flag-o-matic java-pkg-opt-2 multilib
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.code.sf.net/p/freewrl/git"
+ S="${WORKDIR}/${P}/freex3d"
+ SRC_URI=
+ KEYWORDS=
+else
+ SRC_URI="mirror://sourceforge/freewrl/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="VRML97 and X3D compliant browser, library, and web-browser plugin"
+HOMEPAGE="http://freewrl.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="curl debug java libeai motif +nsplugin opencl osc +sox static-libs"
+
+COMMONDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm
+ motif? ( x11-libs/motif:0= )
+ !motif? ( x11-libs/libXaw )
+ media-libs/mesa
+ virtual/opengl
+ media-libs/freealut
+ media-libs/openal
+ media-libs/libpng:0=
+ virtual/jpeg:0=
+ media-libs/imlib2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ curl? ( net-misc/curl )
+ osc? ( media-libs/liblo )
+ opencl? ( virtual/opencl )
+ dev-lang/spidermonkey:0="
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.4 )
+ nsplugin? ( net-misc/npapi-sdk )"
+RDEPEND="${COMMONDEPEND}
+ media-fonts/dejavu
+ || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] )
+ app-arch/unzip
+ java? ( >=virtual/jre-1.4 )
+ sox? ( media-sound/sox )"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ # list of js libs without .pc support, to disable ./configure auto-checking
+ local spidermonkeys=( mozilla-js xulrunner-js firefox-js firefox2-js seamonkey-js )
+ # list of .pc supported spidermonkeys, to disable ./configure auto-checking
+ local spidermonkeys_pc=( mozjs187 mozjs185 )
+
+ local myconf="--enable-fontconfig
+ --without-expat
+ --with-x
+ --with-imageconvert=/usr/bin/convert
+ --with-unzip=/usr/bin/unzip
+ --disable-mozjs-17.0
+ ${spidermonkeys[@]/#/ --disable-}"
+
+ if has_version "<dev-lang/spidermonkey-1.8.5" ; then
+ # spidermonkey pre-1.8.5 has no pkg-config, so override ./configure
+ myconf+="${spidermonkeys_pc[@]/#/ --disable-}"
+ JAVASCRIPT_ENGINE_CFLAGS="-I/usr/include/js -DXP_UNIX"
+ if has_version ">=dev-lang/spidermonkey-1.8:0" ; then
+ # spidermonkey-1.8 changed the name of the lib
+ JAVASCRIPT_ENGINE_LIBS="-lmozjs"
+ else
+ JAVASCRIPT_ENGINE_LIBS="-ljs"
+ fi
+ if has_version "dev-lang/spidermonkey:0[threadsafe]" ; then
+ JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
+ JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
+ fi
+ export JAVASCRIPT_ENGINE_CFLAGS
+ export JAVASCRIPT_ENGINE_LIBS
+ fi
+ if use nsplugin; then
+ myconf+=" --with-plugindir=/usr/$(get_libdir)/${PLUGINS_DIR}"
+ myconf+=" --disable-mozilla-plugin --disable-xulrunner-plugin"
+ fi
+ econf ${myconf} \
+ $(use_enable curl libcurl) \
+ $(use_with opencl OpenCL) \
+ $(use_enable debug) $(use_enable debug thread_colorized) \
+ $(use_enable libeai) \
+ $(use_enable java) \
+ $(use_enable nsplugin plugin) \
+ $(use_enable osc) \
+ $(use_enable static-libs static) \
+ $(use_enable sox sound) \
+ $(usex sox "--with-soundconv=/usr/bin/sox") \
+ $(usex motif "--with-target=motif" "--with-target=x11") \
+ $(usex motif "--with-statusbar=standard" "--with-statusbar=hud")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use java; then
+ insinto /usr/share/${PN}/lib
+ doins src/java/java.policy
+ java-pkg_regjar src/java/vrml.jar
+ # install vrml.jar as a JRE extension
+ dodir /usr/java/packages/lib/ext
+ dosym /usr/share/${PN}/lib/vrml.jar /usr/java/packages/lib/ext/vrml.jar
+ if ! has_version "media-gfx/freewrl[java]" ; then
+ elog "Because vrml.jar requires access to sockets, you will need to incorporate the"
+ elog "contents of /usr/share/${PN}/lib/java.policy into your system or user's default"
+ elog "java policy:"
+ elog " cat /usr/share/${PN}/lib/java.policy >>~/.java.policy"
+ fi
+ fi
+
+ # remove unneeded .la files (as per Flameeyes' rant)
+ cd "${D}"
+ rm "usr/$(get_libdir)"/*.la "usr/$(get_libdir)/${PLUGINS_DIR}"/*.la
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "By default, FreeWRL expects to find the 'firefox' binary in your include"
+ elog "path. If you do not have firefox installed or you wish to use a different"
+ elog "web browser to open links that are within VRML / X3D files, please be sure to"
+ elog "specify the command via your BROWSER environment variable."
+ fi
+}
diff --git a/media-gfx/freewrl/freewrl-9999.ebuild b/media-gfx/freewrl/freewrl-9999.ebuild
index f1c85f6628f8..b2efb486f8fb 100644
--- a/media-gfx/freewrl/freewrl-9999.ebuild
+++ b/media-gfx/freewrl/freewrl-9999.ebuild
@@ -23,16 +23,21 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="curl debug java libeai motif +nsplugin opencl osc +sox static-libs"
-COMMONDEPEND="x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext
+COMMONDEPEND="x11-libs/libICE
+ x11-libs/libSM
x11-libs/libX11
- motif? ( x11-libs/motif )
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm
+ motif? ( x11-libs/motif:0= )
!motif? ( x11-libs/libXaw )
media-libs/mesa
virtual/opengl
- media-libs/libpng
- virtual/jpeg
+ media-libs/freealut
+ media-libs/openal
+ media-libs/libpng:0=
+ virtual/jpeg:0=
media-libs/imlib2
>=media-libs/freetype-2
media-libs/fontconfig
@@ -53,10 +58,6 @@ RDEPEND="${COMMONDEPEND}
sox? ( media-sound/sox )"
src_prepare() {
- if [[ ${PV} != "9999" ]]; then
- epatch "${FILESDIR}"/${P}-fontconfig-match.patch
- epatch "${FILESDIR}"/${P}-mozjs187-config.patch
- fi
epatch_user
eautoreconf
}