summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl-Johan Karlsson <creideiki@ferretporn.se>2017-10-23 09:56:38 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2017-10-23 06:27:05 -0600
commit5b78f8ab4c44e6807398bd6a252ca7c98efcf601 (patch)
tree2203c36f1c94e7c005116027df760b16449fa146
parentsys-process/acct: Stable on amd64 (diff)
downloadgentoo-5b78f8ab4c44e6807398bd6a252ca7c98efcf601.tar.gz
gentoo-5b78f8ab4c44e6807398bd6a252ca7c98efcf601.tar.bz2
gentoo-5b78f8ab4c44e6807398bd6a252ca7c98efcf601.zip
app-crypt/kbfs: build the Git remote helper, #633554
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--app-crypt/kbfs/kbfs-9999.ebuild12
-rw-r--r--app-crypt/kbfs/metadata.xml5
2 files changed, 15 insertions, 2 deletions
diff --git a/app-crypt/kbfs/kbfs-9999.ebuild b/app-crypt/kbfs/kbfs-9999.ebuild
index 4da71bde3c9a..b084faeb8f15 100644
--- a/app-crypt/kbfs/kbfs-9999.ebuild
+++ b/app-crypt/kbfs/kbfs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ EGIT_REPO_URI="https://github.com/keybase/kbfs.git"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="git"
DEPEND="
>=dev-lang/go-1.6:0
@@ -37,8 +37,16 @@ src_compile() {
-tags production \
-o "${T}/kbfsfuse" \
github.com/keybase/kbfs/kbfsfuse
+ use git && \
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/git-remote-keybase" \
+ github.com/keybase/kbfs/kbfsgit/git-remote-keybase
}
src_install() {
dobin "${T}/kbfsfuse"
+ use git && \
+ dobin "${T}/git-remote-keybase"
}
diff --git a/app-crypt/kbfs/metadata.xml b/app-crypt/kbfs/metadata.xml
index b925088bda74..00881f3d617a 100644
--- a/app-crypt/kbfs/metadata.xml
+++ b/app-crypt/kbfs/metadata.xml
@@ -8,4 +8,9 @@
The official Keybase implementation of the client-side code for the
Keybase filesystem (KBFS).
</longdescription>
+ <use>
+ <flag name="git">
+ Build the Git remote helper for storing repositories in Keybase
+ </flag>
+ </use>
</pkgmetadata>