summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-26 19:04:38 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-26 19:04:38 -0400
commit5d0690c19f69c36e995d96a7399750deeac1a390 (patch)
tree66f6fb584589524e87051f0f2ce165d42c1a811b
parentdev-python/tox: version bump to 2.4.1 (diff)
downloadgentoo-5d0690c19f69c36e995d96a7399750deeac1a390.tar.gz
gentoo-5d0690c19f69c36e995d96a7399750deeac1a390.tar.bz2
gentoo-5d0690c19f69c36e995d96a7399750deeac1a390.zip
dev-python/pluggy: version bump to 0.4.0
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-0.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index 76351b4563c6..98165e6b5fa5 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1 +1,2 @@
DIST pluggy-0.3.1.tar.gz 15821 SHA256 159cc783e056c07da6552aa5aef6b1e6c0064b4f18bd49c531fd2d40aafb0ea3 SHA512 ebff28ef6d5eb78d8043fcf3860e43dd80bd800c12f6f744ae2a8757815f94034c858dbd6f4ab35dd4c609d4446aeb1783ace4f54ea6c3de6ec295ec06c7abb8 WHIRLPOOL a1b516135fa770c519994e0e1f045ac1c16e9166f169edc6b5fe79a0b68308273c8c28d6db138f7042dfe95d2e97e5bddd1d7fcfcc3b89cf5e4aee2da9d73c23
+DIST pluggy-0.4.0.zip 19054 SHA256 dd841b5d290b252cf645f75f3bd37ceecfa0f36394ab313e4f785fe68a4081a4 SHA512 1a6e28df05751767df1ac3dfac4c29ba0367f05ae9c8c6a7f5163bb53de36f90226ed18baedeb41bc8ca23504ca61a9b32ef907d3ec3fee7512bcdf45a56d19c WHIRLPOOL 6fe852f807f8966d5df39a118871097758885c95c7aa1e722278704c8ccfaee14e6c18abf7e2033e4801aa0934a2ff0eb64ac3a8db5a53fc86841f6a9cf688cc
diff --git a/dev-python/pluggy/pluggy-0.4.0.ebuild b/dev-python/pluggy/pluggy-0.4.0.ebuild
new file mode 100644
index 000000000000..8d24c3affedf
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE=" http://pypi.python.org/pypi/pluggy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v -v || die
+}