summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-09-29 15:42:12 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-09-30 07:50:39 -0400
commit5d6befa9534be892fb80ff06818f4d867d89590c (patch)
tree03904ed38c12399ec6809bc251ff1a3f8b370477
parentdev-qt: Switch from ~PV to =QT5_PV* version dependencies (diff)
downloadgentoo-5d6befa9534be892fb80ff06818f4d867d89590c.tar.gz
gentoo-5d6befa9534be892fb80ff06818f4d867d89590c.tar.bz2
gentoo-5d6befa9534be892fb80ff06818f4d867d89590c.zip
sci-mathematics/flint: new upstream version 2.8.0.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/flint/Manifest1
-rw-r--r--sci-mathematics/flint/flint-2.8.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-mathematics/flint/Manifest b/sci-mathematics/flint/Manifest
index bf41b8b7db55..04321071c431 100644
--- a/sci-mathematics/flint/Manifest
+++ b/sci-mathematics/flint/Manifest
@@ -1 +1,2 @@
DIST flint-2.7.1.tar.gz 4945081 BLAKE2B 9dcc4b0062be08778cd8ada1794a73237ea091a7bff4a4673aa59eac9b414ed90e0291b9547bdf72aa30e48da11f98ff983267ea2e3dd1d75fcec00b24c86ca9 SHA512 abea97228e91089d82a9a44714e719064bef261c45f5f5b24700955bb841cc98a8182e04e6054fcbcaa3bd92f2f95a82bd5d168ec2171af6a58d4f71eb0a479a
+DIST flint-2.8.0.tar.gz 5209922 BLAKE2B 801c6130b3e8119998c3288d243358f567a843597c425cf5edcd37f6dd0f71a5d796e5dc3c8f3ffb8407f8e6dc01a3f4c62daa758e62eee2bbbf6ed07f1721e0 SHA512 91125f7c3aaccb40768091c36c11b5fb5d1e5010e7cb71145d18d348606baa1e72aeae27baa826c00c4a190c39ef19af9488357d0d5634a7c5774e9aeeaef3fc
diff --git a/sci-mathematics/flint/flint-2.8.0.ebuild b/sci-mathematics/flint/flint-2.8.0.ebuild
new file mode 100644
index 000000000000..c0196d38a199
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.8.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ninja doesn't like "-lcblas" so using make.
+CMAKE_MAKEFILE_GENERATOR="emake"
+PYTHON_COMPAT=( python3_{7..9} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+SRC_URI="http://www.flintlib.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+
+# Based off the soname, e.g. /usr/lib64/libflint.so -> libflint.so.15
+SLOT="0/16"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc ntl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? (
+ dev-python/sphinx
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-tex/latexmk
+ )
+ ${PYTHON_DEPS}"
+DEPEND="dev-libs/gmp:=
+ dev-libs/mpfr:=
+ ntl? ( dev-libs/ntl:= )
+ virtual/cblas"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_NTL="$(usex ntl)"
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_DOCS="$(usex doc)"
+ -DCBLAS_INCLUDE_DIRS="${EPREFIX}/usr/include"
+ -DCBLAS_LIBRARIES="-lcblas"
+ )
+
+ cmake_src_configure
+
+ if use doc ; then
+ HTML_DOCS="${BUILD_DIR}/html/*"
+ DOCS=(
+ "${S}"/README
+ "${S}"/AUTHORS
+ "${S}"/NEWS
+ "${BUILD_DIR}"/latex/Flint.pdf
+ )
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc ; then
+ cmake_build html
+ cmake_build pdf
+ fi
+}