summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-08-05 13:19:04 +0200
committerMike Gilbert <floppym@gentoo.org>2016-08-06 13:25:39 -0400
commit5da22d2ab16d27ac66d1b26d172435cf8cb45013 (patch)
tree47210b7167f8f0442089c3c79368b4546da7c59c
parentDrop package.use.mask on ruby use flag for subversion-1.7 as the 1.7 series h... (diff)
downloadgentoo-5da22d2ab16d27ac66d1b26d172435cf8cb45013.tar.gz
gentoo-5da22d2ab16d27ac66d1b26d172435cf8cb45013.tar.bz2
gentoo-5da22d2ab16d27ac66d1b26d172435cf8cb45013.zip
app-i18n/fcitx-m17n: Initial addition.
-rw-r--r--app-i18n/fcitx-m17n/Manifest1
-rw-r--r--app-i18n/fcitx-m17n/fcitx-m17n-0.2.3.ebuild38
-rw-r--r--app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild34
-rw-r--r--app-i18n/fcitx-m17n/files/fcitx-m17n-0.2.3-memory_leak.patch20
-rw-r--r--app-i18n/fcitx-m17n/metadata.xml12
5 files changed, 105 insertions, 0 deletions
diff --git a/app-i18n/fcitx-m17n/Manifest b/app-i18n/fcitx-m17n/Manifest
new file mode 100644
index 000000000000..640dbe0763e7
--- /dev/null
+++ b/app-i18n/fcitx-m17n/Manifest
@@ -0,0 +1 @@
+DIST fcitx-m17n-0.2.3.tar.xz 33504 SHA256 84f9a9ac9e8c94db0c124d1c9cafa352191894b4d04d926611c5b0759e86de39 SHA512 6e78b70fb2e3139a59f49d25026c075893a8f192dd2083641ab3e56595a4f631ff13307dd647fd0eedd510dade690d97b44cbdeca96e086855f73910dc5d02af WHIRLPOOL e007a15f5908f37c115934e77ffbb446621ca132e87d13dea7aaed98e1cc566f1376229739572664b1cc90a9ef0ed6f4fafec719310a98815a4bc7d70625e5a3
diff --git a/app-i18n/fcitx-m17n/fcitx-m17n-0.2.3.ebuild b/app-i18n/fcitx-m17n/fcitx-m17n-0.2.3.ebuild
new file mode 100644
index 000000000000..27d6b1b3dc93
--- /dev/null
+++ b/app-i18n/fcitx-m17n/fcitx-m17n-0.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-m17n"
+fi
+
+DESCRIPTION="m17n-provided input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-m17n"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-libs/m17n-lib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+PATCHES=(
+ "${FILESDIR}/${P}-memory_leak.patch"
+)
diff --git a/app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild b/app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild
new file mode 100644
index 000000000000..78afc5b98a5e
--- /dev/null
+++ b/app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-m17n"
+fi
+
+DESCRIPTION="m17n-provided input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-m17n"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-libs/m17n-lib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
diff --git a/app-i18n/fcitx-m17n/files/fcitx-m17n-0.2.3-memory_leak.patch b/app-i18n/fcitx-m17n/files/fcitx-m17n-0.2.3-memory_leak.patch
new file mode 100644
index 000000000000..ef89d35075a2
--- /dev/null
+++ b/app-i18n/fcitx-m17n/files/fcitx-m17n-0.2.3-memory_leak.patch
@@ -0,0 +1,20 @@
+https://github.com/fcitx/fcitx-m17n/commit/52d3d740c35845c78857ead8a0537eb7b0d4706f
+
+--- /im/fcitx-m17n.c
++++ /im/fcitx-m17n.c
+@@ -592,6 +592,7 @@
+ } else {
+ iconName = uniqueName;
+ }
++ m17n_object_unref(info);
+
+ FcitxIMIFace iface;
+ memset(&iface, 0, sizeof(FcitxIMIFace));
+@@ -619,6 +620,7 @@
+ free(uniqueName);
+ free(fxName);
+ }
++ m17n_object_unref(mimlist);
+
+ fcitx_utils_free(curlang);
+
diff --git a/app-i18n/fcitx-m17n/metadata.xml b/app-i18n/fcitx-m17n/metadata.xml
new file mode 100644
index 000000000000..49f2185b80dc
--- /dev/null
+++ b/app-i18n/fcitx-m17n/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+</pkgmetadata>