summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarshall Brewer (Gentoo Key) <tomboy64@sina.cn>2016-04-28 18:49:06 +0200
committerAmy Winston <amynka@gentoo.org>2016-05-08 22:14:54 +0200
commit5e5d98bb7afc1c961e89f1aff1738fb37b4ff6f3 (patch)
tree71f141340944b4c36d6d3ff7c1b81dc5f52c011d
parentdev-lang/moarvm: revbump 2016.04-r1 (diff)
downloadgentoo-5e5d98bb7afc1c961e89f1aff1738fb37b4ff6f3.tar.gz
gentoo-5e5d98bb7afc1c961e89f1aff1738fb37b4ff6f3.tar.bz2
gentoo-5e5d98bb7afc1c961e89f1aff1738fb37b4ff6f3.zip
dev-lang/moarvm: re-add 9999, based on 2016.04-r1
-rw-r--r--dev-lang/moarvm/moarvm-9999.ebuild64
1 files changed, 48 insertions, 16 deletions
diff --git a/dev-lang/moarvm/moarvm-9999.ebuild b/dev-lang/moarvm/moarvm-9999.ebuild
index 0b704eb7b3cd..7b75a885f471 100644
--- a/dev-lang/moarvm/moarvm-9999.ebuild
+++ b/dev-lang/moarvm/moarvm-9999.ebuild
@@ -1,36 +1,68 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils git-r3
+inherit flag-o-matic
MY_PN="MoarVM"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://moarvm.org/releases/${MY_PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
DESCRIPTION="A 6model-based VM for NQP and Rakudo Perl 6"
-HOMEPAGE="https://github.com/MoarVM/MoarVM"
-EGIT_REPO_URI="https://github.com/MoarVM/MoarVM.git"
-
+HOMEPAGE="http://moarvm.org"
LICENSE="Artistic-2"
SLOT="0"
-KEYWORDS=""
-IUSE="doc"
+IUSE="asan clang debug doc +jit static-libs +system-libs optimize ubsan"
-RDEPEND=""
+RDEPEND="dev-libs/libatomic_ops
+ dev-libs/libtommath
+ dev-libs/libuv
+ jit? ( dev-lang/lua:0[deprecated]
+ dev-lua/LuaBitOp )
+ virtual/libffi"
DEPEND="${RDEPEND}
+ clang? ( >=sys-devel/clang-3.1 )
dev-lang/perl"
+PATCHES=( "${FILESDIR}/Configure-2016.04.patch" )
+DOCS=( CREDITS README.markdown )
+
+# Tests are conducted via nqp
+RESTRICT=test
+
src_prepare() {
- epatch "${FILESDIR}/Configure-9999.patch" || die
+ eapply "${PATCHES[@]}"
+ eapply_user
+ use doc && DOCS+=( docs/* )
}
src_configure() {
- # this is quite badong, but wtf build system
- echo "2013.10-145-gec52026" >> VERSION
- perl Configure.pl --prefix="${D}/usr"|| die
-}
+ local myconfigargs=(
+ "--prefix=/usr"
+ "--libdir=$(get_libdir)"
+ "--compiler=$(usex clang clang gcc)"
+ "$(usex asan --asan)"
+ "$(usex debug --debug --no-debug)"
+ "$(usex jit --lua=/usr/bin/lua --no-jit)"
+ "$(usex optimize --optimize= --no-optimize)"
+ "$(usex static-libs --static)"
+ "$(usex system-libs --has-libtommath)"
+ "$(usex system-libs --has-libuv)"
+ "$(usex system-libs --has-libatomic_ops)"
+ "$(usex system-libs --has-libffi)"
+ "$(usex ubsan --ubsan)"
+ )
+ use optimize && filter-flags '-O*'
-src_install() {
- make install
+ perl Configure.pl "${myconfigargs[@]}" || die
}