summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-04 12:11:17 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-04 12:12:28 +0200
commit5e96b3523a39ff7fd2c8470477c5dfb3ea442894 (patch)
tree811ccd2682e0e6891594006daa2dd258ba0459b5
parentnet-misc/shigofumi: Switch to HTTPS in EGIT_REPO_URI (diff)
downloadgentoo-5e96b3523a39ff7fd2c8470477c5dfb3ea442894.tar.gz
gentoo-5e96b3523a39ff7fd2c8470477c5dfb3ea442894.tar.bz2
gentoo-5e96b3523a39ff7fd2c8470477c5dfb3ea442894.zip
dev-libs/libmaxminddb: Add live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--dev-libs/libmaxminddb/libmaxminddb-99999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libmaxminddb/libmaxminddb-99999.ebuild b/dev-libs/libmaxminddb/libmaxminddb-99999.ebuild
new file mode 100644
index 000000000000..22ef31d40939
--- /dev/null
+++ b/dev-libs/libmaxminddb/libmaxminddb-99999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="C library for the MaxMind DB file format"
+HOMEPAGE="https://github.com/maxmind/libmaxminddb"
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="Apache-2.0"
+SLOT="0/0.0.7"
+KEYWORDS=""
+IUSE="static-libs"
+
+DOCS=( Changes.md )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}