summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2019-10-19 00:51:16 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-10-19 23:22:09 +0100
commit5ecbed8544680aa105f16e8408ae1a2082686916 (patch)
tree38fa312e6c6d50f73d99fc85430d0b379ca02964
parentpackage.mask: Last rite media-fonts/jsmath-extra-light (diff)
downloadgentoo-5ecbed8544680aa105f16e8408ae1a2082686916.tar.gz
gentoo-5ecbed8544680aa105f16e8408ae1a2082686916.tar.bz2
gentoo-5ecbed8544680aa105f16e8408ae1a2082686916.zip
games-fps/openarena: support building only a server
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Alexey Sokolov <sokolov@google.com> Closes: https://github.com/gentoo/gentoo/pull/13336 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-fps/openarena/metadata.xml3
-rw-r--r--games-fps/openarena/openarena-0.8.8-r1.ebuild39
2 files changed, 25 insertions, 17 deletions
diff --git a/games-fps/openarena/metadata.xml b/games-fps/openarena/metadata.xml
index fb6c4d02068e..ec45d585b91b 100644
--- a/games-fps/openarena/metadata.xml
+++ b/games-fps/openarena/metadata.xml
@@ -5,6 +5,9 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="client">Build OpenArena client</flag>
+ </use>
<upstream>
<remote-id type="sourceforge">oarena</remote-id>
</upstream>
diff --git a/games-fps/openarena/openarena-0.8.8-r1.ebuild b/games-fps/openarena/openarena-0.8.8-r1.ebuild
index 7440f19e8ec0..f9a04f80a0b2 100644
--- a/games-fps/openarena/openarena-0.8.8-r1.ebuild
+++ b/games-fps/openarena/openarena-0.8.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,21 +12,23 @@ SRC_URI="mirror://sourceforge/oarena/${P}.zip
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+curl +openal +vorbis"
+IUSE="+client +curl +openal +vorbis"
RDEPEND="
- media-libs/libsdl[joystick,opengl,video]
- media-libs/speex
- media-libs/speexdsp
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- curl? ( net-misc/curl )
- openal? ( media-libs/openal )
- vorbis? ( media-libs/libvorbis )
+ client? (
+ media-libs/libsdl[joystick,opengl,video]
+ media-libs/speex
+ media-libs/speexdsp
+ virtual/jpeg:0
+ virtual/opengl
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ curl? ( net-misc/curl )
+ openal? ( media-libs/openal )
+ vorbis? ( media-libs/libvorbis )
+ )
"
DEPEND="${RDEPEND}
app-arch/unzip
@@ -52,6 +54,7 @@ src_compile() {
# also build always server and use smp by default
myopts="USE_INTERNAL_SPEEX=0 USE_VOIP=1 USE_MUMBLE=0
BUILD_SERVER=1 BUILD_CLIENT_SMP=1 USE_LOCAL_HEADERS=0"
+ use client || myopts="${myopts} BUILD_CLIENT=0"
use curl || myopts="${myopts} USE_CURL=0"
use openal || myopts="${myopts} USE_OPENAL=0"
use vorbis || myopts="${myopts} USE_CODEC_VORBIS=0"
@@ -67,7 +70,7 @@ src_compile() {
src_install() {
cd "${MY_S}"/"${BUILD_DIR}"
- newbin openarena-smp.* "${PN}"
+ use client && newbin openarena-smp.* "${PN}"
newbin oa_ded.* "${PN}-ded"
cd "${S}"
@@ -75,6 +78,8 @@ src_install() {
doins -r baseoa missionpack
dodoc CHANGES CREDITS LINUXNOTES README
- newicon "${MY_S}"/misc/quake3.png ${PN}.png
- make_desktop_entry ${PN} "OpenArena"
+ if use client; then
+ newicon "${MY_S}"/misc/quake3.png ${PN}.png
+ make_desktop_entry ${PN} "OpenArena"
+ fi
}