summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-06-09 12:18:24 +0200
committerTiziano Müller <dev-zero@gentoo.org>2016-06-09 12:18:24 +0200
commit5ede661d7e0b16436b0ceaace354a5d5219242f2 (patch)
treee2d31811f5fe088c044851d85d47d73b1d90a916
parentdev-python/mongoengine: version bump, add Python-3 support (diff)
downloadgentoo-5ede661d7e0b16436b0ceaace354a5d5219242f2.tar.gz
gentoo-5ede661d7e0b16436b0ceaace354a5d5219242f2.tar.bz2
gentoo-5ede661d7e0b16436b0ceaace354a5d5219242f2.zip
dev-python/python-gnupg: rev-bump for EAPI-6 and added python-3.5 support
Package-Manager: portage-2.3.0_rc1
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild
new file mode 100644
index 000000000000..54eab73a7e70
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch )
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}