summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-10-30 18:00:52 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-30 18:00:52 +0200
commit5f6a456881dcd8b3834585cb6761000d6418527c (patch)
tree11d3e3fac6314f8bf09ea166c81c21a18fd445ae
parentwww-servers/nginx-unit: Remove obsolete ebuild (diff)
downloadgentoo-5f6a456881dcd8b3834585cb6761000d6418527c.tar.gz
gentoo-5f6a456881dcd8b3834585cb6761000d6418527c.tar.bz2
gentoo-5f6a456881dcd8b3834585cb6761000d6418527c.zip
sys-kernel/pf-sources: bump to 5.3-pf5
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.3_p5.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index c1b3d9a3881b..bd9514b0d98b 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -13,3 +13,4 @@ DIST pf-sources-5.3_p1.patch 253654 BLAKE2B f1d4cd4a1d2ad78a918a540c79ec2a7c15c3
DIST pf-sources-5.3_p2.patch 317339 BLAKE2B 7e5f8c3a2cd7f2fae4b038c8178c1d0943b1224fd4898aab6a546fadf7b091177c6d3ce99ffe6bcf298405d9354064aca78695f608c6d695bbb287752e8e9f4b SHA512 8c0c4dabb6925ab6fa1a9379035fcbac9587737be938e13bf0059fa5e55f79ef7f8800f1568dd1192e63e377e832ad628127b239ffc96b06699ee413d7a884f8
DIST pf-sources-5.3_p3.patch 980797 BLAKE2B 96bd53791737fcb1d1503b719a8654a90bd9045ab678289fb457992725b40c6ddd86d4970dc462a3b707de7fc38ecd55b95f0191941fc79777f2b17ba22a9cc8 SHA512 d3bb38efa4174494a6669b77805207d6af1d6b00ff1d887f8f4d3b0f4682548e347ce96e0c1841d4a4f81f0721327b4f2c8d7b169f3b0850a895f1dac2b3d4c3
DIST pf-sources-5.3_p4.patch 1340441 BLAKE2B fe979e8511d6bfa481749e50d8f4f2edc8016477de4edc644cd57015b0568c9948e7643871642ce67a5a9250294e3981951b87a3f60161ceec6232c206031349 SHA512 879991193cd6fd77f17f5fafbfd6172528837c57014a6d220d37cc57cd9bd51ebae9d7687762eb972cea16c37f7e48d440d9d55e7f4532ec09f218cf7a2cac4c
+DIST pf-sources-5.3_p5.patch 1596810 BLAKE2B ba0229daedb6e883192fc3de569601bc2284dfdb012c4a46b7367772aec07570b826e9fb23725b68deac2a35613c44c83ae587dfb2d4787ef5bba39b995535b5 SHA512 7524528d02f4d593eae506c055c414f28875ee3f32334cf420ad4357e41fb8dbd0b3801d98676ca624566351145fde032c1ff8a25f762aa058c9558ffdf014cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.3_p5.ebuild b/sys-kernel/pf-sources/pf-sources-5.3_p5.ebuild
new file mode 100644
index 000000000000..82d79915f607
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.3_p5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+ETYPE="sources"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${PF_URI}
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+ "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}