summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2019-03-14 00:00:13 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-15 23:42:19 +0100
commit6020c496faa3d23842a201b610af58377cbfc1fb (patch)
treeed54cc828b15ff317e3d30f730b304d2e5c93f30
parentmedia-gfx/slic3r: use HTTPS. (diff)
downloadgentoo-6020c496faa3d23842a201b610af58377cbfc1fb.tar.gz
gentoo-6020c496faa3d23842a201b610af58377cbfc1fb.tar.bz2
gentoo-6020c496faa3d23842a201b610af58377cbfc1fb.zip
dev-python/patsy: version bump to 0.5.1.
plus EAPI bump to 7 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Horea Christian <horea.christ@yandex.com> Closes: https://github.com/gentoo/gentoo/pull/11359 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-python/patsy/Manifest1
-rw-r--r--dev-python/patsy/patsy-0.5.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/patsy/Manifest b/dev-python/patsy/Manifest
index 9fe99193ebc9..a19308dff17b 100644
--- a/dev-python/patsy/Manifest
+++ b/dev-python/patsy/Manifest
@@ -1 +1,2 @@
DIST patsy-0.4.1.zip 425390 BLAKE2B b8d5696abcf35fcd5e49a7d3efdfb201976efdbe7e845f136dd0cdbfb0972d8372e54b8f4141139cff9ad4df3525c67a10a3c71bc1471991a810e834e0dd0ad9 SHA512 24cf2e6f9a33e6dd795a839eb2b2ac9e0d45cd9c3d5250de17722914ac29436d0518388d0696b75d73236eda3c7819dc4fa24d6d9bc37d5ae035dde2af4510c3
+DIST patsy-0.5.1.tar.gz 397623 BLAKE2B b8861e8c8e223db5df616c378d5b1ce475a1b337d049723c1a4b01432d9e1569c4b6537dc467fbc1ba83dfc7cd999ad188008e387c446f2133f872393c9eb960 SHA512 aeb56411e68713ec75c0b5344890939f721c460d3c7643b9fd57d7c928421d21408b0f2963348edf27a025842989dbae6fd5cfccd3f9d9497d60a1dffe8d7bdc
diff --git a/dev-python/patsy/patsy-0.5.1.ebuild b/dev-python/patsy/patsy-0.5.1.ebuild
new file mode 100644
index 000000000000..dc375b85bbf6
--- /dev/null
+++ b/dev-python/patsy/patsy-0.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="https://files.pythonhosted.org/packages/49/c7/b971d8685c52512dbaa45bf8d076695432245a9f59509fb20a6c8e4ff69a/patsy-0.5.1.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}