summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:57:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:46 +0100
commit610246b3ad4eff73bf8d16151419ed4d6ec4e61c (patch)
treeec01a18d778b599ef65dba69a3c21953b16fa955
parentnet-wireless/pyrit: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-610246b3ad4eff73bf8d16151419ed4d6ec4e61c.tar.gz
gentoo-610246b3ad4eff73bf8d16151419ed4d6ec4e61c.tar.bz2
gentoo-610246b3ad4eff73bf8d16151419ed4d6ec4e61c.zip
sci-chemistry/chemex: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-chemistry/chemex/chemex-0.6.1-r3.ebuild (renamed from sci-chemistry/chemex/chemex-0.6.1-r2.ebuild)30
1 files changed, 15 insertions, 15 deletions
diff --git a/sci-chemistry/chemex/chemex-0.6.1-r2.ebuild b/sci-chemistry/chemex/chemex-0.6.1-r3.ebuild
index 0b85b22ffc3d..c6facbd71020 100644
--- a/sci-chemistry/chemex/chemex-0.6.1-r2.ebuild
+++ b/sci-chemistry/chemex/chemex-0.6.1-r3.ebuild
@@ -17,22 +17,22 @@ KEYWORDS="~amd64"
IUSE=""
RDEPEND="
- || (
- >=dev-python/matplotlib-python2-1.1[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-1.1[${PYTHON_USEDEP}]
- )
- || (
- dev-python/numpy-python2[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- || (
- >=sci-libs/scipy-python2-0.11[${PYTHON_USEDEP}]
- >=sci-libs/scipy-0.11[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ || (
+ >=dev-python/matplotlib-python2-1.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/matplotlib-1.1[${PYTHON_MULTI_USEDEP}]
+ )
+ || (
+ dev-python/numpy-python2[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ )
+ || (
+ >=sci-libs/scipy-python2-0.11[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/scipy-0.11[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
"
+DEPEND="${RDEPEND}"
src_prepare() {
# Fix quotes to detect the version properly