summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-06 15:42:28 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-06 16:48:15 -0400
commit6121cffabfd54dbcd2f1a9f481ee726f804d0338 (patch)
tree7649cb5e207dd7a555ee02920a86bcb4a2998408
parentapp-emacs/magit: amd64 stable (diff)
downloadgentoo-6121cffabfd54dbcd2f1a9f481ee726f804d0338.tar.gz
gentoo-6121cffabfd54dbcd2f1a9f481ee726f804d0338.tar.bz2
gentoo-6121cffabfd54dbcd2f1a9f481ee726f804d0338.zip
dev-php/pecl-eio: Revbump for php 7.2
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-php/pecl-eio/pecl-eio-2.0.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/pecl-eio/pecl-eio-2.0.2-r1.ebuild b/dev-php/pecl-eio/pecl-eio-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..ed19c8deb059
--- /dev/null
+++ b/dev-php/pecl-eio/pecl-eio-2.0.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PHP_EXT_NAME="eio"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( README.md )
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libeio library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="debug"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS="--with-eio $(use_enable debug eio-debug)"
+ php-ext-source-r3_src_configure
+}