summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 12:37:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commit61d7bc585a702e9381a4bdb2f7871f5fc024f1d4 (patch)
tree036d38aa435724820392955c17dcb89b7b34532f
parentdev-python/unidecode: Add python3.5 support (diff)
downloadgentoo-61d7bc585a702e9381a4bdb2f7871f5fc024f1d4.tar.gz
gentoo-61d7bc585a702e9381a4bdb2f7871f5fc024f1d4.tar.bz2
gentoo-61d7bc585a702e9381a4bdb2f7871f5fc024f1d4.zip
dev-python/pretty-yaml: Add python3.5 support
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=565196 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild b/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild
index 9859e21d3d31..8742877d2e99 100644
--- a/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild
+++ b/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_{3,4}} pypy )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1
@@ -17,9 +18,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/unidecode[${PYTHON_USEDEP}] )"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/unidecode[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_PN}-${PV}"