summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-01-25 20:07:26 -0800
committerZac Medico <zmedico@gentoo.org>2017-01-25 20:09:41 -0800
commit62e74a2bb1fbd1a7a4569ec92c97eb7482fd9b35 (patch)
tree2cd1aa7c5927d5562c71070e0e6299ce4414b296
parentnet-misc/libreswan: remove unused patches/file (diff)
downloadgentoo-62e74a2bb1fbd1a7a4569ec92c97eb7482fd9b35.tar.gz
gentoo-62e74a2bb1fbd1a7a4569ec92c97eb7482fd9b35.tar.bz2
gentoo-62e74a2bb1fbd1a7a4569ec92c97eb7482fd9b35.zip
dev-python/python-engineio: version bump to 1.1.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-1.1.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 880df683bb00..072480970f2f 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,2 +1,3 @@
DIST python-engineio-0.9.1.tar.gz 11812 SHA256 30af19dfe0dba55ba080958d2e251a3bb528c2502b83b255b46c4d90fa1db650 SHA512 69d69e6eb8a577ccf3bdd960c6e32c43111a174458291fe5254028e70f5898644896db67f4884a0e25ecdf20de69521d320787bf75917fffd508d36b11772f01 WHIRLPOOL a13bd82e6d09572466d16fd1771e8e6f13289304a2979e0577e6b37310c9e86d3f122a62e8cca39db289e87def98502ee359778845de39edf264efdf6bb559ea
DIST python-engineio-1.0.3.tar.gz 14801 SHA256 30803f9d3c327a27bdbf6e55a9772c858082c69de87b750ff981effd47386e5c SHA512 09d610bf88cda61eb2232436302eedd46e14bac5071ee298585e731f36ee49449272290b9b3ce34a16d4c37c3598689f5772a0b5162628311d506ad60c0c0ad8 WHIRLPOOL beb558dc726c33503db81cb25489b612fa5e4755646f8b2bab0d642b2d0da5cc813997094b13e4a9e47861e688a7da5310b630351c6e862b2f00f71de3d282de
+DIST python-engineio-1.1.1.tar.gz 13758 SHA256 429cb9120355427138079108057d32824c084f24ca0858d41effc6ec115b0989 SHA512 54c4ae979569e98e6ff0439faf45ccfade4bcbc9b2947805fa9b2b88b40a5ed78f06f64cdf403d76bdb4a2d7f2b1ced2402a179ceb9e924285f96afbe285ca10 WHIRLPOOL e0fcb46c24d22c84337ec8ec4ff06c2b6294258e0d9f69b723d41590760d86eecf302bf602b2582a2212eb1482e98ea1c4753d56e5d5383fb1aca8672f59fe1f
diff --git a/dev-python/python-engineio/python-engineio-1.1.1.ebuild b/dev-python/python-engineio/python-engineio-1.1.1.ebuild
new file mode 100644
index 000000000000..99d606b08efe
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die
+}