summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-27 21:28:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-27 21:58:24 +0200
commit62eb14adde104adbfc5c6c524bba6d274d26f134 (patch)
tree5690964b7631d92013a49b3e410b9ed030ba9634
parentmedia-libs/phonon-vlc: Drop 0.10.3 (diff)
downloadgentoo-62eb14adde104adbfc5c6c524bba6d274d26f134.tar.gz
gentoo-62eb14adde104adbfc5c6c524bba6d274d26f134.tar.bz2
gentoo-62eb14adde104adbfc5c6c524bba6d274d26f134.zip
sys-auth/polkit-qt: 0.113 version bump
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sys-auth/polkit-qt/Manifest1
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/Manifest b/sys-auth/polkit-qt/Manifest
index f8e02f528184..8afcecc75939 100644
--- a/sys-auth/polkit-qt/Manifest
+++ b/sys-auth/polkit-qt/Manifest
@@ -1 +1,2 @@
DIST polkit-qt-1-0.112.0_p20160416.tar.xz 64540 BLAKE2B fbc3631585801f42ff92324576a2bd82d61aa5b24317f95e1182c300073a8e746007fa3409127a50d7d3433c5092f56d72e2e579683d08145067d4424c4dfe7e SHA512 90677af780a2bbcb33b6a54702ba96f965eb8561f2636af7aa0146f9b2450f9e89f67e022ffa99742afe50e3d1f570eabfad686e9e08e629a1e662d9f5abf2ea
+DIST polkit-qt-1-0.113.0.tar.xz 64652 BLAKE2B 52d8c5c8009e2595c70db5b6a6349e4524d6d9cbec12c5a535f25d737da1d16e77fadf3572eebbede7a5ed583c818e878119b416d69a076e03bb37d2f7da7b41 SHA512 deea5d75f547eaa0279c664ec9608b65f464db97fd5fdea27437f8ed4ec033de2b9f91d967deacb28bf0a1e54f131f997acb862cc3e1f8dfcb1f6c337e719b38
diff --git a/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
new file mode 100644
index 000000000000..7191cd244da6
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN}-1"
+MY_P="${MY_PN}-${PV}"
+inherit cmake-utils
+
+DESCRIPTION="Qt wrapper around polkit-1 client libraries"
+HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
+SRC_URI="mirror://kde/stable/${MY_PN}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ )
+
+ cmake-utils_src_configure
+}