summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-01-02 10:59:19 -0500
committerCraig Andrews <candrews@gentoo.org>2018-01-02 10:59:32 -0500
commit62ee6c63068cff1d6526c4fbd3d61d3fb0520a13 (patch)
tree4ad4a3f0ae4d2f4558ea661fbf0f993e94d100d5
parenteclass/cmake-utils: switch Darwin to rpath mode, bug #642668 (diff)
downloadgentoo-62ee6c63068cff1d6526c4fbd3d61d3fb0520a13.tar.gz
gentoo-62ee6c63068cff1d6526c4fbd3d61d3fb0520a13.tar.bz2
gentoo-62ee6c63068cff1d6526c4fbd3d61d3fb0520a13.zip
net-p2p/cpuminer-opt: 3.7.8 version bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.7.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 670da61d7a23..cfd65256dd05 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.7.7.tar.gz 1602520 BLAKE2B 059afdbd90ff062c698432d352fbb9f32807219a24659f5e27990a32b791d868147cf6fa027dff60d2e16d5f43b36b826dbabdc971e4dae4e1473aaf8795b222 SHA512 85989257ef8ee945000621598f6a9c4ed1b8099c57902d570db3038617b787254a925865567541d75e4433aaff564ffc82bd659f645ca812f809602bef8bc7c7
+DIST cpuminer-opt-3.7.8.tar.gz 1611178 BLAKE2B 12082a378fa4656a38e634d692b182a7b5fa09aae24ba4d0226968e35680ed6175999e2daf789cdc7bda960ddd246a663ff54ff6b15435798a84268cfcff4fcc SHA512 19dcfde77405eef78061c13600dfef9ee69f62443e64c4019bdc18f98658ac1c41517f2c12f383edfd94ebcc35a58fbd2fe34037e530705bd2d1465f0355a9ab
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.7.8.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.7.8.ebuild
new file mode 100644
index 000000000000..912415ee00ce
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.7.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ use cpu_flags_x86_avx2 && append-cflags "-DFOUR_WAY"
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}