summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-07-05 20:24:00 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-07-07 07:19:22 +0000
commit6329f9f3f20d3a8178404b7bf05397d34036ab30 (patch)
tree71151374cb43a78351a7901fcd2bf6aa04411ce5
parentdev-python/chump: new package, optional dependency for www-misc/urlwatch (diff)
downloadgentoo-6329f9f3f20d3a8178404b7bf05397d34036ab30.tar.gz
gentoo-6329f9f3f20d3a8178404b7bf05397d34036ab30.tar.bz2
gentoo-6329f9f3f20d3a8178404b7bf05397d34036ab30.zip
www-misc/urlwatch: bump to 2.2, use HTTPS URLs
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/1830 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch42
-rw-r--r--www-misc/urlwatch/metadata.xml2
-rw-r--r--www-misc/urlwatch/urlwatch-2.2.ebuild46
4 files changed, 91 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 332f12624599..19afc97c3ab6 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,3 +1,4 @@
DIST urlwatch-1.18.tar.gz 14987 SHA256 6b17411b6658f3aeb5839d1b32458f020ce40ee1e62a3d40387a2622fa731824 SHA512 ffbfb41e5b6ca71abf19132424dc1bfb3d0cfc30a644615c34539bb5b00acea5803d4c30637c58e9682820c5411227f7c579344c1e212f575431a1c650a7e520 WHIRLPOOL 49915ef83cc835b8ac67216eaeb61391195f28fa28b5716c7e1cc8c8dac465d9f3670beb408c80dc3fa5315683467524b02b1663fb671f26338059acfa247b23
DIST urlwatch-2.0.tar.gz 22988 SHA256 6be8034671788b8c3633d12e16ae69685f0c4341d2c46bed0e847749f8c76848 SHA512 00855557daccf2c418382082392173f03d694be0b6e643ad06fb2a6e0329d17fac37232867686d8e0a6cb79f037e4127a5ea78739bfcd8acfd1cffccf2d78b75 WHIRLPOOL e0f7fce989391aad6f85dc075e91987bfa1e7fcff06d252625716b692a5052f0dac31553e1676522ef7c0df1488f3059c31ba47922a6cf755d47518fe5e90179
DIST urlwatch-2.1.tar.gz 25134 SHA256 6627b753f9c7a908863899b1b4eb9283ef8a630bf78490c6e492275a5919c476 SHA512 60960b41b592d45a29f967d212580b2687afc5d5053adef7c796044e404a4a1e120ea66d8cd0cbf869cccead76373db0d0ab6d6541a77cc4f8885c02b098f6d2 WHIRLPOOL 6a9344d9cbfd0afdc79c0d9af364fba493a9c65f6f4fdf322baf3e5a635e231986789d11428e15c40d89030ff587fc9f9f90833f65109af59bd81cc0f70be193
+DIST urlwatch-2.2.tar.gz 24435 SHA256 a3257ab795adb91514c7163610c7a916ccce9df9ab2cfdef2b72c250ab292069 SHA512 680547d01da6830059048247be4467c68ce9977786f3ba1ec0ad470eb77608b6938c244ed9341ddfd382d65cae167338c685bff2eac91a5f15e881c2aca7bb9b WHIRLPOOL 46d0dce6dc904e15561986e724882592a174c0c2480daf4eac81a4616b7b73d32033b06e70fafad3b399e557365b084e6f7518fa070420ecd22e4340b7b45f96
diff --git a/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch b/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch
new file mode 100644
index 000000000000..66626dbf0259
--- /dev/null
+++ b/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch
@@ -0,0 +1,42 @@
+From ebe7b90100a3d960f53fdc9409d2d89eaa61bf11 Mon Sep 17 00:00:00 2001
+From: Thomas Perl <m@thp.io>
+Date: Tue, 28 Jun 2016 18:15:51 +0200
+Subject: [PATCH] Check current directory and use os.path.relpath (Fixes #73)
+
+---
+ setup.py | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 947a7c8..45405cd 100644
+--- a/setup.py
++++ b/setup.py
+@@ -7,10 +7,15 @@
+
+ import os
+ import re
++import sys
+
+ PACKAGE_NAME = 'urlwatch'
+ DEPENDENCIES = ['minidb', 'PyYAML', 'requests']
+-HERE = os.path.dirname(__file__)
++HERE = os.path.abspath(os.path.dirname(__file__))
++
++if os.path.normpath(os.getcwd()) != os.path.normpath(HERE):
++ print('You must run {} inside {} (cwd={})'.format(os.path.basename(__file__), HERE, os.getcwd()))
++ sys.exit(1)
+
+ # Assumptions:
+ # 1. Package name equals main script file name (and only one script)
+@@ -29,9 +34,9 @@
+
+ m['scripts'] = [os.path.join(HERE, PACKAGE_NAME)]
+ m['package_dir'] = {'': os.path.join(HERE, 'lib')}
+-m['packages'] = ['.'.join(dirname[len(HERE)+1:].split(os.sep)[1:])
++m['packages'] = ['.'.join(os.path.relpath(dirname, HERE).split(os.sep)[1:])
+ for dirname, _, files in os.walk(os.path.join(HERE, 'lib')) if '__init__.py' in files]
+-m['data_files'] = [(dirname[len(HERE)+1:], [os.path.join(dirname[len(HERE)+1:], fn) for fn in files])
++m['data_files'] = [(os.path.relpath(dirname, HERE), [os.path.join(os.path.relpath(dirname, HERE), fn) for fn in files])
+ for dirname, _, files in os.walk(os.path.join(HERE, 'share')) if files]
+ m['install_requires'] = DEPENDENCIES
+
diff --git a/www-misc/urlwatch/metadata.xml b/www-misc/urlwatch/metadata.xml
index 7be78803734f..66d70930108d 100644
--- a/www-misc/urlwatch/metadata.xml
+++ b/www-misc/urlwatch/metadata.xml
@@ -7,5 +7,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">urlwatch</remote-id>
+ <remote-id type="github">thp/urlwatch</remote-id>
+ <bugs-to>https://github.com/thp/urlwatch/issues</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/www-misc/urlwatch/urlwatch-2.2.ebuild b/www-misc/urlwatch/urlwatch-2.2.ebuild
new file mode 100644
index 000000000000..a9d7a735c7d8
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
+SRC_URI="https://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ || ( www-client/lynx app-text/html2text )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-install.patch" )
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] && \
+ ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+}