summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-19 22:16:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-19 23:30:27 +0200
commit639441c61b80d3c2aa31d1ae05ac257a26130063 (patch)
treefd237416bf2c8b9ecc1ba1e5254ef0d96e52f2e1
parentdev-ml/biniou: bump to 1.2.0 (diff)
downloadgentoo-639441c61b80d3c2aa31d1ae05ac257a26130063.tar.gz
gentoo-639441c61b80d3c2aa31d1ae05ac257a26130063.tar.bz2
gentoo-639441c61b80d3c2aa31d1ae05ac257a26130063.zip
dev-ml/yojson: bump to 1.4.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-ml/yojson/Manifest1
-rw-r--r--dev-ml/yojson/yojson-1.4.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index 09e86138732b..ca650320012c 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1 +1,2 @@
DIST yojson-1.3.3.tar.gz 26940 SHA256 de5ad4fd681f58ae5a670f0a43684873cc6ca50bdf52e63ac0c4b8a8bbe1d51a SHA512 78d88d470bb64360d020ebc70d9faaa7abca6476fd20d0224e188b44d147c42cea8723adff0845e5444d684b2d0e186154cca288cb236de94a83a44229fcb426 WHIRLPOOL 4594fdd1b6e467afb204b319d3672100eb3a8ccf88cdb47c4c60fbbdb339df9694695f75e63ecef8a3c8aa1096a7fc3e3d864229ffbb244900c2084ce3e48afc
+DIST yojson-1.4.0.tar.gz 26197 SHA256 7d06340b769ed6ff5b2171a0e820d1e8f4337aef3929090fc976efe845639146 SHA512 dc019ecf0387299282c3df9a548456d2529993241911a83acb14f2361ed14886e5ebebe415773b6bc718cb0b12a25529184f3b5b62c71b42960fbd62e1c63bf6 WHIRLPOOL d48c6fd6f05349139b8d3fc847d479ad4bfa28ad2fec42f58660ce482955548e961fd19efab5969f686ca2e528d0b38686d255778b9a0812d8c0eccd255435c5
diff --git a/dev-ml/yojson/yojson-1.4.0.ebuild b/dev-ml/yojson/yojson-1.4.0.ebuild
new file mode 100644
index 000000000000..5de703f5a055
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html https://github.com/mjambon/yojson"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ >=dev-ml/biniou-1.2:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ dev-ml/jbuilder
+ dev-ml/cppo
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}