summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-24 00:06:18 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-24 00:06:18 +0000
commit658964bad0f252d4b6f3a8b6582771eb9ded2a38 (patch)
tree0098cab3accd3541fbea4f2f9ae0d9b65e9a00e6
parentgnome-extra/assogiate: depend on C++11 enabled packages and use it as std, bu... (diff)
parentdev-python/httmock: version bump to 1.2.3 (diff)
downloadgentoo-658964bad0f252d4b6f3a8b6582771eb9ded2a38.tar.gz
gentoo-658964bad0f252d4b6f3a8b6582771eb9ded2a38.tar.bz2
gentoo-658964bad0f252d4b6f3a8b6582771eb9ded2a38.zip
Merge remote-tracking branch 'github/pr/515'.
-rw-r--r--dev-python/httmock/Manifest1
-rw-r--r--dev-python/httmock/httmock-1.2.3.ebuild25
-rw-r--r--dev-python/httmock/metadata.xml21
3 files changed, 35 insertions, 12 deletions
diff --git a/dev-python/httmock/Manifest b/dev-python/httmock/Manifest
index e6ffa3424571..6eb9009284f9 100644
--- a/dev-python/httmock/Manifest
+++ b/dev-python/httmock/Manifest
@@ -1 +1,2 @@
DIST httmock-1.2.2.tar.gz 4975 SHA256 4dd4eddd8dba38c2b279c6fc7487fb92e91b1ae5d945a496bf059ea2b2aaf06c SHA512 0be8ae754bd3ae34166b0b001a44e664b07488ba6d44ed3dc518b310b82418dc5ab2f15ef13cb20909109f19c22a6e13dfdfdfa37f26f3c0688b19f2321be767 WHIRLPOOL 7d1315845e7a72975d5e0f8ae483f17b5e033a230cf020c770e804091c7a0ef5e94c4649720db3f3f5c68d2a19d7a45ab5d696118719967913e4c1ee01f9234c
+DIST httmock-1.2.3.tar.gz 5203 SHA256 030cca3f3210b902aaa28524183dc061a2ef9afd3da6a9b40ce0c09d28d50d4d SHA512 23b7295f2685639eba44714b3dadbd6eca20b7f50e636d6490d5c3f581429d84e1f4b1e15f4ba31a7ccee1596768003e68a7f1591b75aeb3d5811b279b3f1bb1 WHIRLPOOL 4eea5a2637e88309a19a05ba5788f8d53a062f0e54458d9ace1e3262affc4104c7953ebceaef52c5fdabcc5b30a520557e75ca5aaa0473159a286d3340200221
diff --git a/dev-python/httmock/httmock-1.2.3.ebuild b/dev-python/httmock/httmock-1.2.3.ebuild
new file mode 100644
index 000000000000..c34228d46c0b
--- /dev/null
+++ b/dev-python/httmock/httmock-1.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A mocking library for requests"
+HOMEPAGE="https://github.com/patrys/httmock"
+SRC_URI="https://github.com/patrys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/httmock/metadata.xml b/dev-python/httmock/metadata.xml
index e8c60cc3448d..e89fb65d5770 100644
--- a/dev-python/httmock/metadata.xml
+++ b/dev-python/httmock/metadata.xml
@@ -1,16 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>proxy-maintainers</herd>
- <maintainer>
- <email>idella4@gentoo.org</email>
- </maintainer>
- <maintainer>
- <email>hydrapolic@gmail.com</email>
- <name>Tomas Mozes</name>
- <description>Proxy maintainer and target for all bugs</description>
- </maintainer>
- <upstream>
- <remote-id type="github">patrys/httmock</remote-id>
- </upstream>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomas Mozes</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">patrys/httmock</remote-id>
+ </upstream>
</pkgmetadata>