summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-18 01:09:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-18 08:17:43 +0200
commit65f5b7aa072b113dbb11a124675fbd6d86bbeeb5 (patch)
tree69d8b5ed732bfdda9cf2bc4b99469f51c0e4f8ce
parentdev-qt/qtdeclarative: Fix subpixel positioned text (diff)
downloadgentoo-65f5b7aa072b113dbb11a124675fbd6d86bbeeb5.tar.gz
gentoo-65f5b7aa072b113dbb11a124675fbd6d86bbeeb5.tar.bz2
gentoo-65f5b7aa072b113dbb11a124675fbd6d86bbeeb5.zip
dev-qt/qtdeclarative: Drop 5.14.2-r1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.14.2-r1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r1.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r1.ebuild
deleted file mode 100644
index 5eb5c48069c0..000000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2009-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="The QML and Quick modules for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-IUSE="gles2-only +jit localstorage vulkan +widgets"
-
-BDEPEND="${PYTHON_DEPS}"
-# qtgui[gles2-only=] is needed because of bug 504322
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2-only=,vulkan=]
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qttest-${PV}
- localstorage? ( ~dev-qt/qtsql-${PV} )
- widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
-"
-RDEPEND="${DEPEND}
- !<dev-qt/qtquickcontrols-5.7:5
-"
-
-PATCHES=("${FILESDIR}/${P}-QQuickItemView-fix-maxXY-extent.patch" ) # QTBUG-83890
-
-src_prepare() {
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
-
- qt_use_disable_mod localstorage sql \
- src/imports/imports.pro
-
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/qmltest/qmltest.pro \
- tests/auto/auto.pro \
- tools/tools.pro \
- tools/qmlscene/qmlscene.pro \
- tools/qml/qml.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myqmakeargs=(
- --
- -qml-debug
- )
- qt5-build_src_configure
-}