summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 20:34:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 20:34:00 -0800
commit6661c0e43627b030005c41af0a38b868149d91bc (patch)
tree75ba3d1697e319d19e00e799373e824cbbe10fc0
parentdev-python/path-py: Make sure the right package name is in the egg (diff)
downloadgentoo-6661c0e43627b030005c41af0a38b868149d91bc.tar.gz
gentoo-6661c0e43627b030005c41af0a38b868149d91bc.tar.bz2
gentoo-6661c0e43627b030005c41af0a38b868149d91bc.zip
dev-python/pytest-virtualenv: Version bump to 1.7.0
Also add RESTRICT="!test? ( test )" Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pytest-virtualenv/Manifest1
-rw-r--r--dev-python/pytest-virtualenv/pytest-virtualenv-1.2.11.ebuild1
-rw-r--r--dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild34
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-virtualenv/Manifest b/dev-python/pytest-virtualenv/Manifest
index 12cb8d540df0..de67e14fca82 100644
--- a/dev-python/pytest-virtualenv/Manifest
+++ b/dev-python/pytest-virtualenv/Manifest
@@ -1 +1,2 @@
DIST pytest-virtualenv-1.2.11.tar.gz 9528 BLAKE2B 2ddcba76f89d207e8efaac8d59c6c1209fb9557fcfad586e1226b70d49ed8093aab602149335d23d497b0674e606d00d289fc291dd721aa7470f12ec221b5f61 SHA512 317ef8717f0ad4da6d38167f1f0dd65b6f1b3bd08bd1361fe6a27e6e422cd9fab62f3fac3848082bb24411505ecd41495fc1cbedb970d43945c8f6f8cfbbdf41
+DIST pytest-virtualenv-1.7.0.tar.gz 15767 BLAKE2B 5ee65aff72c50c8facef682827f58a8053d658aa072f3a69d50d13335dda2da37ffc29af009b52a50349647a4a38e149ba1b9847115fc4b4c4f54f063198b14f SHA512 0463ebf44ae18ee50a60e421a22aaaf0e34f827ec8f21c8f0dc79cbdc253748f9d1e5b33e4f418b52f0d8fd45990e162bb6410686ebe9fdc02650c286901d474
diff --git a/dev-python/pytest-virtualenv/pytest-virtualenv-1.2.11.ebuild b/dev-python/pytest-virtualenv/pytest-virtualenv-1.2.11.ebuild
index 75e402ea41f0..6b52cfbc679a 100644
--- a/dev-python/pytest-virtualenv/pytest-virtualenv-1.2.11.ebuild
+++ b/dev-python/pytest-virtualenv/pytest-virtualenv-1.2.11.ebuild
@@ -30,6 +30,7 @@ DEPEND="
dev-python/mock[${PYTHON_USEDEP}]
)
"
+RESTRICT="!test? ( test )"
python_test() {
esetup.py test
diff --git a/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild
new file mode 100644
index 000000000000..0f53a35b999e
--- /dev/null
+++ b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.org/project/pytest-virtualenv/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-shutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py