summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2015-10-06 14:12:01 +0200
committerUltrabug <ultrabug@gentoo.org>2015-10-06 14:12:01 +0200
commit67520589f24b84cfc85ea27424560bf5633f5604 (patch)
tree4c051377351729a8cea833377e1b1d18afb2ea11
parentdev-haskell/hsopenssl: add libressl support (diff)
downloadgentoo-67520589f24b84cfc85ea27424560bf5633f5604.tar.gz
gentoo-67520589f24b84cfc85ea27424560bf5633f5604.tar.bz2
gentoo-67520589f24b84cfc85ea27424560bf5633f5604.zip
dev-python/pymongo: version bump
Package-Manager: portage-2.2.22
-rw-r--r--dev-python/pymongo/Manifest1
-rw-r--r--dev-python/pymongo/pymongo-2.9.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index f2f31dacf6d2..d15c92401e62 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,4 +1,5 @@
DIST pymongo-2.6.3.tar.gz 324241 SHA256 cabe1d785ad5db6ed8ff70dcb9c987958fc75400f066ec78911ca3f37184a4e2 SHA512 6da3cbf035b52379c24df37b76e1eb743b12c1026116e28e4e7b6450e2674d730f9c8c2dd85f352c6ee4c9f604decaffc2dbc57fe64268bd7522d8ce155cca9e WHIRLPOOL ac36dd88c4311237ecda66a6008fa0d89d0670e331df6c49a08a1d3bc4ddcafe72e8e003009c206d3ac12afb1b14afe2d3615834a5a8df5ce30442f7b49fdbf2
DIST pymongo-2.7.2.tar.gz 381455 SHA256 8fb45e3edec006f4b11580fc579bec7781a8b3201ce0abf31593f086070e51f6 SHA512 0e78495462d670c168e716a7c34e05f6a11a203f0bf9b32c1488608343588a48cbbb76ce715411b310359de19d9cd57c75f80ac7d8195a122a760cec22e8d0c7 WHIRLPOOL 6cb7eedc530908c2fdb17b6e31561d9c860d6fd1edddb4d66288c3fe11bc199ebc58538a70508b2540b827077f62345a86729644fdf8d37c1b9934de03e77543
DIST pymongo-2.8.1.tar.gz 399521 SHA256 300ea5762d059c07d1bb2578f35bd0e55bc31753951e2de3d6fe2ed54438e374 SHA512 8d02829eb8683572ffe8c1be5ee50a4c778e1a0b938820859be215b583e719d079183b1a26bc074fad7e31e8944756b82b146657ad528123514b59c725f6d7aa WHIRLPOOL b0c8c373771d3a4525ddf30db5903a6b1241aa1e160e688c215bef21395d598faa65f12e57ea8fe0f16d1c0eaa0abad02ebf3e0b9df2acb8e1c8e6ff9c20a214
+DIST pymongo-2.9.tar.gz 430741 SHA256 90e994cfe5928841960dabdca709e75ab4d0f44b288fd59742113982d96290c4 SHA512 c12701797643b41503829b6c7e573cfff7d8c63c56d9eb195f1a67dc3204cd7ed2a28ee2bd2ce34d0c68bade3f44c8bd5c069b15082bf3388c3a401a35424b1e WHIRLPOOL 699a7f658734837f40fe4190251f8e8bb69dba80bbc6dba60207bb18d5dfb43ec5d1c6aca8810b45e7914705305416d0f76face88fd0c43aa20c6d0765eff01c
DIST pymongo-3.0.3.tar.gz 419692 SHA256 3c6b2317f8031bc1e200fd1ea35f00a96f4569e3f3f220a5e66ab6227d96ccaf SHA512 7a20fdcae5b3f852bded19c95b36ef6a8141bce0179440a2c5966cbb9f18f3985b7b6b4584c5253c34d0f846d809d72ec0ae076c88472a3de6f090466e9132b4 WHIRLPOOL ae610909b610c7d116dd3aa7c04ab9ce357b25208b07c025924c53bb36183a6d344ecff214def6a01b929dc50d698464c8dd33b6eafd2d88d6666d8534858a38
diff --git a/dev-python/pymongo/pymongo-2.9.ebuild b/dev-python/pymongo/pymongo-2.9.ebuild
new file mode 100644
index 000000000000..059bdf55ecaf
--- /dev/null
+++ b/dev-python/pymongo/pymongo-2.9.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit check-reqs distutils-r1
+
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.python.org/pypi/pymongo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc kerberos test"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-db/mongodb-2.6.0
+ )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+python_compile_all() {
+ if use doc; then
+ mkdir html || die
+ sphinx-build doc html || die
+ fi
+}
+
+src_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ # 1.5G of disk space per run.
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --smallfiles --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ if [[ "${EPYTHON}" == python3* ]]; then
+ 2to3 --no-diffs -w test
+ fi
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+
+ distutils-r1_python_install_all
+}