summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-05 08:17:38 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-05 08:17:38 +0000
commit682f4d1c2967af1a94d94b693782300aea2d32ce (patch)
tree584351f008655b10b846f682b5ec8558a38e94c5
parentsys-auth/consolekit: Update live ebuild (diff)
parentdev-libs/libucl: New package (diff)
downloadgentoo-682f4d1c2967af1a94d94b693782300aea2d32ce.tar.gz
gentoo-682f4d1c2967af1a94d94b693782300aea2d32ce.tar.bz2
gentoo-682f4d1c2967af1a94d94b693782300aea2d32ce.zip
Merge remote-tracking branch 'github/pr/784'.
-rw-r--r--dev-libs/libucl/Manifest1
-rw-r--r--dev-libs/libucl/libucl-0.7.3.ebuild45
-rw-r--r--dev-libs/libucl/metadata.xml25
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/libucl/Manifest b/dev-libs/libucl/Manifest
new file mode 100644
index 000000000000..7f98a55840e8
--- /dev/null
+++ b/dev-libs/libucl/Manifest
@@ -0,0 +1 @@
+DIST libucl-0.7.3.tar.gz 1986726 SHA256 2f69995c7f8320350f56c1183c395cc4a2a958331f22d60b7839a117c9c601e1 SHA512 29b466254887f7be1168ce31de9f852f3f1868a3afaa5a73859a4cd43b915510850e786ff778613fa48579ee6f0f78e5898c83ce9423f1fb688cce8d969a8eab WHIRLPOOL 2f72d5a5b938719f59661abe827cfc7f0b20db22c478fdc98c40d664c652d0b67096aa82b5ec161d3212bfd38924b3be364bd797ea090ec620f7c2efc82a4157
diff --git a/dev-libs/libucl/libucl-0.7.3.ebuild b/dev-libs/libucl/libucl-0.7.3.ebuild
new file mode 100644
index 000000000000..585a76baa977
--- /dev/null
+++ b/dev-libs/libucl/libucl-0.7.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Universal configuration library parser"
+HOMEPAGE="https://github.com/vstakhov/libucl"
+SRC_URI="https://github.com/vstakhov/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="lua +regex signatures static-libs urlfetch utils"
+DEPEND="lua? ( >=dev-lang/lua-5.1:= )
+ signatures? ( dev-libs/openssl:0 )
+ urlfetch? ( net-misc/curl )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/api.md )
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local myeconf=""
+ use urlfetch && myeconf="--with-urls"
+ econf \
+ $(use_enable lua) \
+ $(use_enable regex) \
+ $(use_enable signatures) \
+ $(use_enable utils) \
+ ${myeconf}
+}
+
+src_install() {
+ default
+ use lua && DOCS+=( doc/lua_api.md )
+ # no .a's it seems
+ use static-libs || find "${ED}" -name "*.la" -delete
+}
diff --git a/dev-libs/libucl/metadata.xml b/dev-libs/libucl/metadata.xml
new file mode 100644
index 000000000000..4f528bc055ec
--- /dev/null
+++ b/dev-libs/libucl/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Co-maintainer, CC on bugs.</description>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>UCL is heavily infused by nginx configuration as the example
+ of a convenient configuration system. However, UCL is fully compatible with
+ JSON format and is able to parse json files. It can also emit UCL objects
+ into different formats such as "nginx like", json, yaml and
+ compact json</longdescription>
+ <use>
+ <flag name="regex">Enable regex checking for schema</flag>
+ <flag name="signatures">Enable signatures check</flag>
+ <flag name="urlfetch">Enable URLs fetch</flag>
+ <flag name="utils">Builds and installs utils</flag>
+ </use>
+</pkgmetadata>