summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-19 05:23:10 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-19 05:24:42 +1300
commit68a4197d1232cf025d423c549dba31677ac55556 (patch)
treea18d878fe928f68762bed106c57de3a7bc49d8bc
parentmedia-libs/ilmbase: tests are known to be broken, bug #632259 (diff)
downloadgentoo-68a4197d1232cf025d423c549dba31677ac55556.tar.gz
gentoo-68a4197d1232cf025d423c549dba31677ac55556.tar.bz2
gentoo-68a4197d1232cf025d423c549dba31677ac55556.zip
dev-perl/UltraDNS: Fix test failures due to '.' in @INC, bug #623144
- EAPI6 - Parallel tests - Fix '.' in @INC test failure - Purge unwanted author tests - Fix unwanted installation of build script Bug: https://bugs.gentoo.org/623144 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-perl/UltraDNS/UltraDNS-0.60.0-r2.ebuild28
-rw-r--r--dev-perl/UltraDNS/files/UltraDNS-0.06-dotinc.patch80
-rw-r--r--dev-perl/UltraDNS/files/UltraDNS-0.06-nomkmethods.patch20
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-perl/UltraDNS/UltraDNS-0.60.0-r2.ebuild b/dev-perl/UltraDNS/UltraDNS-0.60.0-r2.ebuild
new file mode 100644
index 000000000000..638784a3ba8b
--- /dev/null
+++ b/dev-perl/UltraDNS/UltraDNS-0.60.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Client API for the NeuStar UltraDNS Transaction Protocol"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-perl/Net-SSLeay-1.350.0
+ dev-perl/Test-Exception
+ >=dev-perl/RPC-XML-0.640.0
+ dev-perl/XML-LibXML"
+RDEPEND="${DEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.06-dotinc.patch"
+ "${FILESDIR}/${PN}-0.06-nomkmethods.patch"
+)
+PERL_RM_FILES=("t/perlcritic.t" "t/perlcritic" "t/pod-coverage.t" "t/pod.t")
+mydoc="NUS_API_XML.errata"
diff --git a/dev-perl/UltraDNS/files/UltraDNS-0.06-dotinc.patch b/dev-perl/UltraDNS/files/UltraDNS-0.06-dotinc.patch
new file mode 100644
index 000000000000..490b5aa2c827
--- /dev/null
+++ b/dev-perl/UltraDNS/files/UltraDNS-0.06-dotinc.patch
@@ -0,0 +1,80 @@
+From 93c5a7666ea83f5b0ba56ca0a8fdee492f65ca87 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 19 Mar 2018 04:58:48 +1300
+Subject: Fix test failures without '.' in @INC
+
+Also explode more readily when runtime dependency resolution fails.
+
+Bug: https://bugs.gentoo.org/623144
+---
+ t/01-connect.t | 2 +-
+ t/02-basic.t | 2 +-
+ t/03-err.t | 2 +-
+ t/30-get.t | 2 +-
+ t/util.pl | 1 +
+ 5 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/t/01-connect.t b/t/01-connect.t
+index 39ffb00..d489d4d 100644
+--- a/t/01-connect.t
++++ b/t/01-connect.t
+@@ -4,7 +4,7 @@ use Test::Exception;
+
+ use UltraDNS;
+
+-do 't/util.pl';
++require './t/util.pl';
+
+ my ($hp,$s,$u,$p) = test_connect_args();
+
+diff --git a/t/02-basic.t b/t/02-basic.t
+index d4b6df5..9a98639 100644
+--- a/t/02-basic.t
++++ b/t/02-basic.t
+@@ -4,7 +4,7 @@ use Test::Exception;
+
+ use UltraDNS;
+
+-do 't/util.pl';
++require './t/util.pl';
+
+ my $udns = test_connect();
+ my $rr;
+diff --git a/t/03-err.t b/t/03-err.t
+index 797c452..0f4c6e1 100644
+--- a/t/03-err.t
++++ b/t/03-err.t
+@@ -4,7 +4,7 @@ use Test::Exception;
+
+ use UltraDNS;
+
+-do 't/util.pl';
++require './t/util.pl';
+
+ my ($hp,$s,$u,$p) = test_connect_args();
+
+diff --git a/t/30-get.t b/t/30-get.t
+index e3c2997..ce193e9 100644
+--- a/t/30-get.t
++++ b/t/30-get.t
+@@ -4,7 +4,7 @@ use Test::Exception;
+
+ use UltraDNS;
+
+-do 't/util.pl';
++require './t/util.pl';
+
+ my $udns = test_connect();
+ my $rr;
+diff --git a/t/util.pl b/t/util.pl
+index 269452b..e36b752 100644
+--- a/t/util.pl
++++ b/t/util.pl
+@@ -72,3 +72,4 @@ END {
+ eval { $_->(); 1 } or warn $@ for @at_end;
+ }
+
++1;
+--
+2.16.2
+
diff --git a/dev-perl/UltraDNS/files/UltraDNS-0.06-nomkmethods.patch b/dev-perl/UltraDNS/files/UltraDNS-0.06-nomkmethods.patch
new file mode 100644
index 000000000000..96c907263676
--- /dev/null
+++ b/dev-perl/UltraDNS/files/UltraDNS-0.06-nomkmethods.patch
@@ -0,0 +1,20 @@
+From 16a92623e2005718af58d7ed0628fb2d4c7b2d51 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 19 Mar 2018 05:06:23 +1300
+Subject: Stop installing mk_methods.pl to the host
+
+---
+ INSTALL.SKIP | 1 +
+ 1 file changed, 1 insertion(+)
+ create mode 100644 INSTALL.SKIP
+
+diff --git a/INSTALL.SKIP b/INSTALL.SKIP
+new file mode 100644
+index 0000000..1699662
+--- /dev/null
++++ b/INSTALL.SKIP
+@@ -0,0 +1 @@
++mk_methods\.pl$
+--
+2.16.2
+