summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 14:35:42 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 14:51:33 +0200
commit68e866ca2e8abf24c76df6aad40d6e00803cf12d (patch)
treea026cd698e029280d0c7f7568027fae799709598
parentdev-python/pillow: Bump to 6.1.0 (diff)
downloadgentoo-68e866ca2e8abf24c76df6aad40d6e00803cf12d.tar.gz
gentoo-68e866ca2e8abf24c76df6aad40d6e00803cf12d.tar.bz2
gentoo-68e866ca2e8abf24c76df6aad40d6e00803cf12d.zip
dev-python/pillow: Spawn one virtx for all testing
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pillow/pillow-6.1.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pillow/pillow-6.1.0.ebuild b/dev-python/pillow/pillow-6.1.0.ebuild
index 7a4b5480a0a8..ca751b2624ca 100644
--- a/dev-python/pillow/pillow-6.1.0.ebuild
+++ b/dev-python/pillow/pillow-6.1.0.ebuild
@@ -79,10 +79,14 @@ python_compile_all() {
use doc && emake -C docs html
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
# no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
- virtx pytest -vv -p no:relaxed
+ pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
}
python_install() {