summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-08 16:55:34 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-09 22:52:12 +0100
commit69d830b8a39f884ce2586b4294dbade618e8a772 (patch)
tree91dd370d170e3eb4596972453e8c24e7932c1ac4
parentx11-themes/gtk-engines-qtpixmap: Reword DESCRIPTION (diff)
downloadgentoo-69d830b8a39f884ce2586b4294dbade618e8a772.tar.gz
gentoo-69d830b8a39f884ce2586b4294dbade618e8a772.tar.bz2
gentoo-69d830b8a39f884ce2586b4294dbade618e8a772.zip
x11-misc/dsx: EAPI bump 2 -> 6, migrate to python-single-r1
Fixes: https://bugs.gentoo.org/599800 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3882
-rw-r--r--x11-misc/dsx/dsx-0.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/dsx/dsx-0.1-r1.ebuild b/x11-misc/dsx/dsx-0.1-r1.ebuild
new file mode 100644
index 000000000000..bb4c35bd7364
--- /dev/null
+++ b/x11-misc/dsx/dsx-0.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Command line selection of your X desktop environment"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+ x11-apps/xinit"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp "${FILESDIR}/${P}" "${PN}" || die
+ default
+}
+
+src_install() {
+ python_doscript "${WORKDIR}/${PN}"
+}