summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-04 13:59:26 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-04 14:17:58 +0300
commit69fa30e8dbc662c52fcef424799c2919a9f358c1 (patch)
treede602e9a01a6d15e3db6bf791b8209126aaf5b07
parentdev-lisp/sbcl: Stable newer version on amd64 #662244 (diff)
downloadgentoo-69fa30e8dbc662c52fcef424799c2919a9f358c1.tar.gz
gentoo-69fa30e8dbc662c52fcef424799c2919a9f358c1.tar.bz2
gentoo-69fa30e8dbc662c52fcef424799c2919a9f358c1.zip
gnome-base/dconf-editor: bump to 3.26.2
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--gnome-base/dconf-editor/Manifest1
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.26.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index 09783c31bfe7..f4fd0ed3b430 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1 +1,2 @@
DIST dconf-editor-3.24.3.tar.xz 503520 BLAKE2B 57b0b0de36e2bb5cef33e0171e77f506f16f240d5ab4ab79d7689b7541ce445bce4d87753f312cf9353b2aa44d5cb2f7c734050a5f57ba2b7eae9894fb74d0e3 SHA512 10c98df210cd465e21601342963a19cd5a255abfaa6e96c833070db52d13531288237a129471bf9424d7ea8fef4c2cd4954652850bbb57dd161ce9cf99265361
+DIST dconf-editor-3.26.2.tar.xz 542828 BLAKE2B e7bd35b39d7b0124105513d44f3a24d005f1c6daf2dccb1d3eeb324b65038adfc11e5ee83078058489b1e918222538a97621c74fb0a0ceb20e1a708ccf5a82bd SHA512 25a6536c97b4f6fc26890915e2d0ed3ff1d2247175fd25a7d86e44f33da8667064415b22890c799d3586cd0f08becc90414f02bf3d988aa1d02eee90d7e45ba5
diff --git a/gnome-base/dconf-editor/dconf-editor-3.26.2.ebuild b/gnome-base/dconf-editor/dconf-editor-3.26.2.ebuild
new file mode 100644
index 000000000000..919e9dfa03ec
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.26.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://git.gnome.org/browse/dconf-editor"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+COMMON_DEPEND="
+ dev-libs/appstream-glib
+ >=dev-libs/glib-2.46.0:2
+ >=gnome-base/dconf-0.25.1
+ >=x11-libs/gtk+-3.22.0:3
+"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/dconf-0.22[X]
+"
+
+src_configure() {
+ gnome2_src_configure \
+ VALAC="$(type -P true)"
+}