summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-12 11:48:37 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-12 16:25:26 +0100
commit6a758c0d1706de233b373a2cd2f34320c62be459 (patch)
treeb77d4fab70dc6a83bfba42116c329ca1de723e41
parentdev-ml/llvm-ocaml: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo (diff)
downloadgentoo-6a758c0d1706de233b373a2cd2f34320c62be459.tar.gz
gentoo-6a758c0d1706de233b373a2cd2f34320c62be459.tar.bz2
gentoo-6a758c0d1706de233b373a2cd2f34320c62be459.zip
sys-devel/lld: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo
-rw-r--r--sys-devel/lld/lld-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-devel/lld/lld-9999.ebuild b/sys-devel/lld/lld-9999.ebuild
index 08ee2985b246..aafd47f0a906 100644
--- a/sys-devel/lld/lld-9999.ebuild
+++ b/sys-devel/lld/lld-9999.ebuild
@@ -5,6 +5,8 @@
EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils git-r3
@@ -27,6 +29,9 @@ DEPEND="${RDEPEND}
# TODO: fix test suite to build stand-alone
RESTRICT="test"
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
src_unpack() {
if use test; then
# needed for patched gtest