summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-17 06:26:58 +0000
committerSam James <sam@gentoo.org>2022-01-17 06:26:58 +0000
commit6b1f12b618de51fd2f750d87f28b5bbc992d37ad (patch)
treef36e4fb293044bb3502d5ace493e25c599378a10
parentnet-dialup/minicom: fix sysconfdir (diff)
downloadgentoo-6b1f12b618de51fd2f750d87f28b5bbc992d37ad.tar.gz
gentoo-6b1f12b618de51fd2f750d87f28b5bbc992d37ad.tar.bz2
gentoo-6b1f12b618de51fd2f750d87f28b5bbc992d37ad.zip
dev-cpp/tbb: add another musl patch
Closes: https://bugs.gentoo.org/828704 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-cpp/tbb/files/tbb-2021.5.0-musl-mallinfo.patch32
-rw-r--r--dev-cpp/tbb/tbb-2021.5.0.ebuild2
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/tbb/files/tbb-2021.5.0-musl-mallinfo.patch b/dev-cpp/tbb/files/tbb-2021.5.0-musl-mallinfo.patch
new file mode 100644
index 000000000000..e46c16f42f59
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-2021.5.0-musl-mallinfo.patch
@@ -0,0 +1,32 @@
+https://cgit.openembedded.org/meta-openembedded/tree/meta-oe/recipes-support/tbb/tbb/0001-mallinfo-is-glibc-specific-API-mark-it-so.patch
+https://github.com/oneapi-src/oneTBB/pull/203
+https://bugs.gentoo.org/828704
+
+From: Naveen Saini <naveen.kumar.saini@intel.com>
+Date: Wed, 7 Apr 2021 11:14:13 +0800
+Subject: [PATCH] mallinfo() is glibc specific API mark it so
+
+Helps compiling with musl
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
+--- a/src/tbbmalloc_proxy/proxy.cpp
++++ b/src/tbbmalloc_proxy/proxy.cpp
+@@ -260,6 +260,7 @@ int mallopt(int /*param*/, int /*value*/
+ return 1;
+ }
+
++#ifdef __GLIBC__
+ struct mallinfo mallinfo() __THROW
+ {
+ struct mallinfo m;
+@@ -267,6 +268,7 @@ struct mallinfo mallinfo() __THROW
+
+ return m;
+ }
++#endif
+
+ #if __ANDROID__
+ // Android doesn't have malloc_usable_size, provide it to be compatible
diff --git a/dev-cpp/tbb/tbb-2021.5.0.ebuild b/dev-cpp/tbb/tbb-2021.5.0.ebuild
index 2ab975036c65..1fa9bfc11894 100644
--- a/dev-cpp/tbb/tbb-2021.5.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.5.0.ebuild
@@ -26,6 +26,8 @@ PATCHES=(
# should be in.. 2022?
"${FILESDIR}"/${PN}-2021.4.0-lto.patch
"${FILESDIR}"/${PN}-2021.5.0-musl-deepbind.patch
+ # need to verify this is in master
+ "${FILESDIR}"/${PN}-2021.5.0-musl-mallinfo.patch
)
src_configure() {