summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-02-10 10:14:20 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-02-10 10:14:20 +0100
commit6b2a8ebd355c9bdb7a759590157eb8b3ab83c6b8 (patch)
tree96af0369f195e97634fee039c36faf296aa7552a
parentsys-libs/libcap: Bump to version 2.25 (diff)
downloadgentoo-6b2a8ebd355c9bdb7a759590157eb8b3ab83c6b8.tar.gz
gentoo-6b2a8ebd355c9bdb7a759590157eb8b3ab83c6b8.tar.bz2
gentoo-6b2a8ebd355c9bdb7a759590157eb8b3ab83c6b8.zip
sys-power/acpid: Bump to version 2.0.26
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-power/acpid/Manifest1
-rw-r--r--sys-power/acpid/acpid-2.0.26.ebuild69
-rw-r--r--sys-power/acpid/files/acpid-2.0.26-init.d20
3 files changed, 90 insertions, 0 deletions
diff --git a/sys-power/acpid/Manifest b/sys-power/acpid/Manifest
index 49ce46371387..9909c3b0e813 100644
--- a/sys-power/acpid/Manifest
+++ b/sys-power/acpid/Manifest
@@ -1,2 +1,3 @@
DIST acpid-2.0.23.tar.xz 154504 SHA256 4396aaec13510c3a1faa941a15a4b5335b6ae4fbec8438b9249b88c3b66187ee SHA512 b2f01f04a9c5370608016c16ecfbc5b503170c2686e6557ab1463e25d56a3ef1d2093d4701205ec1261564b1073653b404d0ae278c0bd8c8496606be1785963f WHIRLPOOL b9c7d4d64e663ffb9c58d2129b4f599453b4da0111b244269cf89ca50cc2de7ecdbea361825724963ee0b93294cadde12dee06c4816f5b709a23e7d443df0afd
DIST acpid-2.0.25.tar.xz 154124 SHA256 0b700a8072bec162c512f72cbe419195601ab3e0ffd2138f9bd95ed3097a5c68 SHA512 8a2561549aa05d1dd763a973145b37bedf935df1d73310b09bd52473b51fdc14bbb10da6e4bd1c2086962d92bd12f3a03924cfe75b2d50bf95b50ded9b67b05f WHIRLPOOL 0431f03df75334731ca40310a579eecac87b4023818eb9ca26b2e7152a74417fae9426efc2389688e5456b4d666f6aa191272bf956bfef21f9667f41e476c17a
+DIST acpid-2.0.26.tar.xz 154856 SHA256 8384f37e4f260f50183e2e20039823d8f06aed9db56924fe92097b7e0b2e0343 SHA512 45c6ee388500a4f80db9177af5006ef490fcc44a2a899cd2d05977797025b4a8076dc5dc68c03d8df85062c47ba5dcf4f6041c3ed5950ecc9626b320cdbb6749 WHIRLPOOL f11be9af83ac0a124e1b69c8f438aa0818dae330d0ff30b5e1650fcaa811d9411e66a0b1d689fcb5e864145c62f6fff20cf7b8fcef980dbee80d6880af34ce43
diff --git a/sys-power/acpid/acpid-2.0.26.ebuild b/sys-power/acpid/acpid-2.0.26.ebuild
new file mode 100644
index 000000000000..6895146bf2ce
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.26.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit linux-info systemd
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://sourceforge.net/projects/acpid2"
+SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-apm )"
+DEPEND=">=sys-kernel/linux-headers-3"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~INPUT_EVDEV"
+ local WARNING_INPUT_EVDEV="CONFIG_INPUT_EVDEV is required for ACPI button event support."
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+pkg_setup() { :; }
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.25-kde4.patch #515088
+ "${FILESDIR}"/${PN}-2.0.25-add_mate-power-manager.patch #538590
+)
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newdoc kacpimon/README README.kacpimon
+ dodoc -r samples
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING || die
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ exeinto /etc/acpi/actions
+ newexe samples/powerbtn/powerbtn.sh powerbtn.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.26-init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.0.16-conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}.{service,socket}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "https://wiki.gentoo.org/wiki/Power_management/Guide"
+ elog
+ fi
+
+ # files/systemd/acpid.socket -> ListenStream=/run/acpid.socket
+ mkdir -p "${ROOT%/}"/run
+
+ if ! grep -qs "^tmpfs.*/run " "${ROOT%/}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+}
diff --git a/sys-power/acpid/files/acpid-2.0.26-init.d b/sys-power/acpid/files/acpid-2.0.26-init.d
new file mode 100644
index 000000000000..7f3ff3c72ab8
--- /dev/null
+++ b/sys-power/acpid/files/acpid-2.0.26-init.d
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload"
+command="/usr/sbin/acpid"
+command_args="${ACPID_ARGS}"
+description="Daemon for Advanced Configuration and Power Interface"
+
+depend() {
+ need localmount
+ use logger
+}
+
+reload() {
+ ebegin "Reloading acpid configuration"
+ start-stop-daemon --exec $command --signal HUP
+ eend $?
+}