summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Santos <joaompssantos@gmail.com>2017-10-28 15:50:43 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-10-28 18:29:33 +0200
commit6bcb33228308f85f6986d11cde536a750309d7cb (patch)
treea8bb5bfd33af7864f761c6dbc4e883209110dddc
parentdev-ruby/neovim-ruby-client: version bump to 0.5.1 (diff)
downloadgentoo-6bcb33228308f85f6986d11cde536a750309d7cb.tar.gz
gentoo-6bcb33228308f85f6986d11cde536a750309d7cb.tar.bz2
gentoo-6bcb33228308f85f6986d11cde536a750309d7cb.zip
app-text/master-pdf-editor: new ebuild.
Master PDF Editor is a straightforward, easy-to-use application to work with PDF documents and equipped with powerful multi-purpose functionalities. With Master PDF Editor you can easily view, create and modify PDF documents. Find out more at https://code-industry.net/masterpdfeditor Closes: https://bugs.gentoo.org/635690 Closes: https://github.com/gentoo/gentoo/pull/6059
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-4.3.61.ebuild72
-rw-r--r--app-text/master-pdf-editor/metadata.xml12
-rw-r--r--licenses/master-pdf-editor94
4 files changed, 179 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
new file mode 100644
index 000000000000..7435e33fc0ab
--- /dev/null
+++ b/app-text/master-pdf-editor/Manifest
@@ -0,0 +1 @@
+DIST master-pdf-editor-4.3.61_qt5.amd64.tar.gz 14950654 SHA256 d54ea747dc17bc5fb3020495688be529d4c8c7314b7703d171d71bc82cead5bc SHA512 0c416df191a2796fdafa6014c258166d47037039fcc9205398138a46d59b1f771d9ffe38eb16f22f4300c3e965435300037d7413a86efb997395e6e974baecb5 WHIRLPOOL 5a40bf8589abcfb9681a920cca686f160f482d330c1086a3af6bf8ce11678ff3cc362ebdb60b8e0c4bb36852d378e70ae0aa017c859689580300408def39b706
diff --git a/app-text/master-pdf-editor/master-pdf-editor-4.3.61.ebuild b/app-text/master-pdf-editor/master-pdf-editor-4.3.61.ebuild
new file mode 100644
index 000000000000..7f5e919d6361
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-4.3.61.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils eutils versionator
+
+DESCRIPTION="Master PDF Editor is a complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+
+SRC_URI="http://get.code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ dev-libs/double-conversion
+ dev-libs/glib
+ dev-libs/icu
+ dev-libs/openssl
+ media-gfx/graphite2
+ media-gfx/sane-backends
+ media-libs/freetype
+ media-libs/harfbuzz
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/tiff
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ >=dev-qt/qtsvg-5.4:5
+ >=dev-qt/qtnetwork-5.4:5
+ >=dev-qt/qtgui-5.4:5
+ >=dev-qt/qtprintsupport-5.4:5
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_major_version ${PV})"
+
+src_install() {
+ local dest=/opt/${PN}
+ local bin_name=masterpdfeditor4
+
+ insinto ${dest}
+ doins -r fonts lang stamps templates ${bin_name}.png
+
+ exeinto ${dest}
+ doexe ${bin_name}
+
+ dosym ${dest}/${bin_name} /opt/bin/${bin_name}
+ make_desktop_entry ${bin_name} \
+ "Master PDF Editor ${PV}" ${dest}/${bin_name}.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ sed -i -e \
+ '/^Exec=/s/masterpdfeditor4/masterpdfeditor4 %f/' \
+ /usr/share/applications/masterpdfeditor4-${PN}.desktop || die
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-text/master-pdf-editor/metadata.xml b/app-text/master-pdf-editor/metadata.xml
new file mode 100644
index 000000000000..82340dc648a0
--- /dev/null
+++ b/app-text/master-pdf-editor/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>joaompssantos@gmail.com</email>
+ <name>Joao Santos</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/licenses/master-pdf-editor b/licenses/master-pdf-editor
new file mode 100644
index 000000000000..2c8f8e52ba81
--- /dev/null
+++ b/licenses/master-pdf-editor
@@ -0,0 +1,94 @@
+aster PDF Editor
+Copyright © Code Industry Ltd All rights reserved.
+
+-------------------------------------------------------------
+
+LICENSE AGREEMENT
+
+Code Industry Ltd (hereinafter referred to as the “Author”)
+hereby grants you a non-exclusive license (hereinafter referred to as
+the “License”) to use the software Master PDF Editor (hereinafter
+referred to as the “Software”) on the terms set forth hereunder.
+
+1. GRANT OF LICENSE.
+This License grants you the following rights. By installing the
+Software you accept the License and agree to comply with it.
+
+2. SOFTWARE.
+Install and use one copy of the Software for a single user. You may
+also install a copy for that user’s exclusive use on either a home
+or portable computer.
+If you want to install and use the copy in the network (on a computer
+file server) you need to purchase an additional license for all users
+with access to this Software.
+
+3. NON-COMMERCIAL USE.
+You are hereby granted to use this Software for non-commercial
+purposes without charge for unlimited time on Desktop Linux. Some
+advanced functionality is locked for non-commercial use. Software can
+also be used for viewing and printing documents only on Windows and
+macOS for unlimited time without any charge.
+
+4. REVERSE ENGINEERING.
+You may not modify, reverse engineer, decompile, disassemble, or
+create derivative works based on the Software, or any portion hereof.
+
+5. RENTAL.
+You may not rent or lease the Software.
+
+6. TRANSFER.
+You may transfer the Software to a single recipient on a permanent
+basis provided that you retain no copies of the Software (including
+backup or archival copies) and the recipient agrees to the terms and
+conditions of this License.
+
+7. TERMINATION.
+The License is in effect until terminated. The License will terminate
+automatically if you fail to comply with the limitations described
+herein. On termination, you must destroy all copies of the Software
+and Documentation.
+
+8. USE OF LOGOS AND TRADEMARKS.
+You may not use the Author’s name, logos, or trademarks in any
+manner including, without limitation, in your advertising or
+marketing materials, except as is necessary to affix the appropriate
+copyright notices as required herein.
+
+9. MISCELLANEOUS.
+This Agreement represents the complete agreement concerning this
+License between the parties and supersedes all prior agreements and
+representations between them. This Agreement may be amended only in
+writing and when executed by both parties. THE ACCEPTANCE OF ANY
+PURCHASE ORDER PLACED BY YOU IS EXPRESSLY MADE CONDITIONAL ON YOUR
+ASSENT TO THE TERMS SET FORTH HEREIN, AND NOT THOSE CONTAINED IN YOUR
+PURCHASE ORDER. If any provision of this Agreement is held to be
+unenforceable for any reason, such a provision shall be reformed only
+to the extent necessary to make it enforceable and the remainder of
+this Agreement shall nonetheless remain in full force and effect.
+
+10. LIMITED WARRANTY:
+THE SOFTWARE IS PROVIDED “AS IS” WITHOUT A WARRANTY OF ANY KIND.
+TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE AUTHOR FURTHER
+DISCLAIMS ALL WARRANTIES, INCLUDING WITHOUT LIMITATION ANY IMPLIED
+WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NON INFRINGEMENT. THE ENTIRE RISK ARISING OUT OF THE USE OR
+PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION REMAINS WITH THE
+RECIPIENT.
+
+11. LIMITATION OF LIABILITY:
+UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, TORT, CONTRACT, OR
+OTHERWISE, SHALL THE AUTHOR OR HIS SUPPLIERS OR RESELLERS BE LIABLE
+TO YOU OR ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR
+CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION,
+DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR
+MALFUNCTION, DATA LOSS, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR
+LOSSES, OR FOR ANY DAMAGES IN EXCESS OF THE AUTHOR’S LIST PRICE FOR
+A LICENSE TO THE SOFTWARE AND DOCUMENTATION, EVEN IF THE AUTHOR SHALL
+HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY
+CLAIM BY ANY OTHER PARTY. THIS LIMITATION OF LIABILITY SHALL NOT
+APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT THAT
+THE APPLICABLE LAW PROHIBITS SUCH LIMITATION. FURTHERMORE, SOME
+STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR
+CONSEQUENTIAL DAMAGES AND, THEREFORE, THIS LIMITATION AND EXCLUSION
+MAY NOT APPLY TO YOU.
+