summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-04-27 00:04:17 -0400
committerMike Gilbert <floppym@gentoo.org>2017-04-27 00:04:17 -0400
commit6be6d71b928d0ce74611604592c7e74cce70b0ab (patch)
treeda54c9f118969b7d5a893b1bda2ff1ae0e7f88eb
parentsys-apps/systemd: meson tweaks (diff)
downloadgentoo-6be6d71b928d0ce74611604592c7e74cce70b0ab.tar.gz
gentoo-6be6d71b928d0ce74611604592c7e74cce70b0ab.tar.bz2
gentoo-6be6d71b928d0ce74611604592c7e74cce70b0ab.zip
sys-apps/systemd: EPREFIX tweaks
Package-Manager: Portage-2.3.5_p31, Repoman-2.3.2_p61
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 60be1bfc79b7..aacb665331db 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -199,9 +199,10 @@ meson_ml_use() {
multilib_src_configure() {
local myconf=(
--buildtype=plain
- --prefix=/usr
+ --prefix="${EPREFIX}/usr"
--libdir="$(get_libdir)"
- --localstatedir=/var
+ --sysconfdir="${EPREFIX}/etc"
+ --localstatedir="${EPREFIX}/var"
-Dpamlibdir="$(getpam_mod_dir)"
# avoid bash-completion dep
-Dbashcompletiondir="$(get_bashcompdir)"
@@ -313,9 +314,9 @@ multilib_src_install_all() {
dosym "..${ROOTPREFIX%/}/lib/systemd/systemd" /sbin/init
else
# we just keep sysvinit tools, so no need for the mans
- rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
+ rm "${ED%/}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
|| die
- rm "${D}"/usr/share/man/man1/init.1 || die
+ rm "${ED%/}"/usr/share/man/man1/init.1 || die
fi
# Preserve empty dirs in /etc & /var, bug #437008
@@ -328,13 +329,13 @@ multilib_src_install_all() {
# If we install these symlinks, there is no way for the sysadmin to remove them
# permanently.
- rm "${D}"/etc/systemd/system/multi-user.target.wants/systemd-networkd.service || die
- rm -f "${D}"/etc/systemd/system/multi-user.target.wants/systemd-resolved.service || die
- rm -r "${D}"/etc/systemd/system/network-online.target.wants || die
- rm -r "${D}"/etc/systemd/system/sockets.target.wants || die
- rm -r "${D}"/etc/systemd/system/sysinit.target.wants || die
+ rm "${ED%/}"/etc/systemd/system/multi-user.target.wants/systemd-networkd.service || die
+ rm -f "${ED%/}"/etc/systemd/system/multi-user.target.wants/systemd-resolved.service || die
+ rm -r "${ED%/}"/etc/systemd/system/network-online.target.wants || die
+ rm -r "${ED%/}"/etc/systemd/system/sockets.target.wants || die
+ rm -r "${ED%/}"/etc/systemd/system/sysinit.target.wants || die
- rm -r "${D}${ROOTPREFIX%/}/lib/udev/hwdb.d" || die
+ rm -r "${ED%/}${ROOTPREFIX%/}/lib/udev/hwdb.d" || die
}
migrate_locale() {
@@ -403,7 +404,7 @@ pkg_postinst() {
# Keep this here in case the database format changes so it gets updated
# when required. Despite that this file is owned by sys-apps/hwids.
if has_version "sys-apps/hwids[udev]"; then
- udevadm hwdb --update --root="${ROOT%/}"
+ udevadm hwdb --update --root="${EROOT%/}"
fi
udev_reload || FAIL=1